Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 03:59

Подскажите новичку как в ТЧ вывести данные при изменении

Автор Сергей Поляков, 07 апр 2022, 03:52

0 Пользователей и 1 гость просматривают эту тему.

Сергей Поляков

Всем привет.

Есть документ, в табличной части мы выбираем из справочника элемент "клиент", и нужно в событии "при изменении" в колонке "ОстатокДенег" (реквизиты табличной части) вывести остаток по этому клиенту, из регистра накопления.

Код:

&НаСервереБезКонтекста
Функция ПолучитьОстаток(Клиент, ДатаДокумента)
      
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ОплатаЗанятийОстатки.СуммаОплатыОстаток КАК СуммаОплатыОстаток
      |ИЗ
      |   РегистрНакопления.ОплатаЗанятий.Остатки(&ДатаДокумента, Клиент= &Клиент) КАК ОплатаЗанятийОстатки";
   
   Запрос.УстановитьПараметр("ДатаДокумента", КонецДня(ДатаДокумента));
   Запрос.УстановитьПараметр("Клиент", Клиент);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Если ВыборкаДетальныеЗаписи.Следующий() Тогда
      ОстатокДенег = ВыборкаДетальныеЗаписи.СуммаОплатыОстаток;
      Возврат ОстатокДенег;
   Иначе
      Возврат 0;
   КонецЕсли;
   
КонецФункции

&НаКлиенте
Процедура УчастникиКлиентПриИзменении(Элемент)
   
   ТекущиеДанные = Элементы.Участники.ТекущиеДанные;
   ТекущиеДанные.ОстатокДенег = ПолучитьОстаток(ТекущиеДанные.Танцор, Элементы.Дата);
      
КонецПроцедуры

Ругается: Отсутствует отображение для типа "Поле формы"

понимаю что на клиента нельзя передать значение, но как обойти, не могу понять. подскажите где не правильно?
спасибо.


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск