Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 03:44

Ошибка при открытии файла

Автор Алексей_1985_06, 03 апр 2022, 15:01

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Всем привет, прошу помочь разобраться в чем заключается ошибка? В РегистреСведений реквизит АдресДокументаВХ - получяет адрес из ХЗ, диалог открытия файла срабатывает, но при нажатии на кнопку Открыть/Сохранить выскакивает ошибка! Знатоки, подскажите что не так?


&НаСервере

Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

// Записываем адрес файла:
Если  ЭтоАдресВременногоХранилища(АдресДокументаВХ) Тогда // АдресДокументаВХ - реквизит с типом "Строка"
ТекущийОбъект.АдресДокумента = Новый ХранилищеЗначения (ПолучитьИзВременногоХранилища(АдресДокументаВХ)); // АдресДокумента - ХранилищеЗначения

ТекущийОбъект.НазваниеДокумента = Запись.НазваниеДокумента;
ТекущийОбъект.ТипФайла = Запись.ТипФайла;

КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Если Запись.НазваниеДокумента = "" Тогда 
Возврат
КонецЕсли;

АдресДокументаВХ = ПолучитьНавигационнуюСсылку(Запись.ИсходныйКлючЗаписи, "АдресДокумента");

КонецПроцедуры

&НаКлиенте
Процедура Получить(Команда)

ПараметрыДиалогаСохраненияФайла = Новый ПараметрыДиалогаПолученияФайлов();
ПараметрыДиалогаСохраненияФайла.Заголовок = НСтр("ru = 'Выберите путь для сохранения файла'; en = 'Select the path to save the file'");

Если Запись.НазваниеДокумента = ""  Тогда   
Сообщить("Нет файла для сохранения");
Возврат
КонецЕсли;


НачатьПолучениеФайлаССервера(АдресДокументаВХ, Запись.НазваниеДокумента+Запись.ТипФайла, ПараметрыДиалогаСохраненияФайла);

КонецПроцедуры


Ошибка получения файлов
по причине:
Неправильный путь к файлу '/e1cib/data/РегистрСведений.БиблиотекаДокументов.АдресДокумента?Период=20220403000000&НазваниеДокумента=%D0%91%D0%BE%D0%B5%D1%81%D0%BF%D0%BE%D1%81%D0%BE%D0%B1%D0%BD%D0%BE%D1%81%D1%82%D1%8C&НомерИздания=%D1%86%D1%86%D1%86%D1%86%D1%86&Система=ae5de86a64'

Алексей_1985_06


P.S. Видимо что-то не так делаю с ключем записи РС, т.к когда одна запись в РС - то все открывается и работает нормально, стоит добавить еще одну запись и выскакивает ошибка (см.выше). Помогите решить данный вопрос, сам никак не могу дойти до истины.....

Алексей_1985_06

Цитата: Алексей_1985_06 от 03 апр 2022, 15:01Всем привет, прошу помочь разобраться в чем заключается ошибка? В РегистреСведений реквизит АдресДокументаВХ - получяет адрес из ХЗ, диалог открытия файла срабатывает, но при нажатии на кнопку Открыть/Сохранить выскакивает ошибка! Знатоки, подскажите что не так?


&НаСервере

Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

// Записываем адрес файла:
Если  ЭтоАдресВременногоХранилища(АдресДокументаВХ) Тогда // АдресДокументаВХ - реквизит с типом "Строка"
ТекущийОбъект.АдресДокумента = Новый ХранилищеЗначения (ПолучитьИзВременногоХранилища(АдресДокументаВХ)); // АдресДокумента - ХранилищеЗначения

ТекущийОбъект.НазваниеДокумента = Запись.НазваниеДокумента;
ТекущийОбъект.ТипФайла = Запись.ТипФайла;

КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Если Запись.НазваниеДокумента = "" Тогда 
Возврат
КонецЕсли;

АдресДокументаВХ = ПолучитьНавигационнуюСсылку(Запись.ИсходныйКлючЗаписи, "АдресДокумента");

КонецПроцедуры

&НаКлиенте
Процедура Получить(Команда)

ПараметрыДиалогаСохраненияФайла = Новый ПараметрыДиалогаПолученияФайлов();
ПараметрыДиалогаСохраненияФайла.Заголовок = НСтр("ru = 'Выберите путь для сохранения файла'; en = 'Select the path to save the file'");

Если Запись.НазваниеДокумента = ""  Тогда   
Сообщить("Нет файла для сохранения");
Возврат
КонецЕсли;


НачатьПолучениеФайлаССервера(АдресДокументаВХ, Запись.НазваниеДокумента+Запись.ТипФайла, ПараметрыДиалогаСохраненияФайла);

КонецПроцедуры


Ошибка получения файлов
по причине:
Неправильный путь к файлу '/e1cib/data/РегистрСведений.БиблиотекаДокументов.АдресДокумента?Период=20220403000000&НазваниеДокумента=%D0%91%D0%BE%D0%B5%D1%81%D0%BF%D0%BE%D1%81%D0%BE%D0%B1%D0%BD%D0%BE%D1%81%D1%82%D1%8C&НомерИздания=%D1%86%D1%86%D1%86%D1%86%D1%86&Система=ae5de86a64'

Форумчане! Ну кто-то может помочь с данным вопросом? Весь мозг сломал, никак не могу разобраться!

Теги:

Похожие темы (5)

13678

Ответов: 11
Просмотров: 7928

62179

Ответов: 6
Просмотров: 32262

44152

Ответов: 5
Просмотров: 3375

Рейтинг@Mail.ru Rambler's Top100

Поиск