Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 окт 2022, 08:59

Условное оформление в обычном приложении

Автор Egor97, 31 мар 2022, 14:53

0 Пользователей и 1 гость просматривают эту тему.

Egor97

Здравствуйте. Как через СписокПриПолученииДанных в обычном приложении реализовать раскраску строк. Может быть есть у кого пример

Ивашка

Egor97, вот пример:
Процедура тзСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
Если ДанныеСтроки.Состояние = Перечисления.СостоянияОбъектов.Согласован Тогда
ОформлениеСтроки.ЦветФона = WebЦвета.БледноЗеленый
КонецЕсли;
КонецПроцедуры

ls600

На форме списка документов делал так.
Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

Попытка
Если ДанныеСтроки.Брутто = 0 Тогда
ОформлениеСтроки.ЦветФона = WebЦвета.ЛососьСветлый;
Иначе
ОформлениеСтроки.ЦветФона = WebЦвета.Белый;
КонецЕсли;
Исключение
КонецПопытки;

КонецПроцедуры


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск