Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 ноя 2022, 18:43

Вопрос по 1С:Предприятие 8.3, учебная версия

Автор юлия_Maltseva250795, 29 мар 2022, 09:14

0 Пользователей и 1 гость просматривают эту тему.

юлия_Maltseva250795

Как увеличить каждый второй элемент массива в три раза.
То есть дан массив действительных чисел, размерность которого N, нужно увеличить каждый второй элемент массива в 3 раза. Подскажите пожалуйста как это сделать

LexaK

юлия_Maltseva250795, вот куча подсказок
1.изменять массив так же  в цикле
2.индексация массива начинается с 0 поэтому второй элемент массива имеет индекс 1, четвертый - 3 и т.д.
3.увеличить в 3 раза - просто перемножить лкМассив[Индекс] = лкМассив[Индекс] * 3;
если помогло нажмите: Спасибо!

Oscar

юлия_Maltseva250795,

Примерно так:

// Для Цикл
    Для Счетчик = 1 По N Цикл
        ДелатьУмножениеНа3;
        Счетчик = Счетчик + 2;
    КонецЦикла;

юлия_Maltseva250795

LexaK, &НаКлиенте
Процедура Задача4(Команда)
   кМассив = СтрРазделить (ВведитеЧислаЧерезПробел, " ");
   Для Счётчик = 1 по  кМассив.Количество(); Цикл
   Счётчик=Счётчик+2;
   кМассив[Индекс] = кМассив[Индекс] * 3;
   КонецЦикла;   
КонецПроцедуры

Выдаёт ошибку: Неопознанный оператор
   Для Счётчик = 1 по  кМассив.Количество(); <<?>>Цикл (Проверка: Тонкий клиент)

Oscar

юлия_Maltseva250795,

Для Счётчик = 1 по  кМассив.Количество(); Цикл

Удалите в строке ;

Oscar

юлия_Maltseva250795,
А откуда у Вас Индекс появился?

кМассив[Индекс] = кМассив[Индекс] * 3

Oscar

юлия_Maltseva250795,
&НаКлиенте
Процедура Задача4(Команда)
 
   кМассив = СтрРазделить (ВведитеЧислаЧерезПробел, " ");
   Для Счётчик = 1 по  кМассив.Количество() Цикл
    кМассив[Счетчик] = кМассив[Счетчик] * 3;
    Счётчик=Счётчик+2;
   КонецЦикла;   

КонецПроцедуры

юлия_Maltseva250795

Oscar, Выдаёт ошибку теперь: Переменная не определена (Счетчик)

Oscar

юлия_Maltseva250795,
А так

&НаКлиенте
Процедура Задача4(Команда)
 
   кМассив = СтрРазделить (ВведитеЧислаЧерезПробел, " ");
   Для Счётчик = 1 по  кМассив.Количество() Цикл
    кМассив[Счётчик] = кМассив[Счётчик] * 3;
    Счётчик=Счётчик+2;
   КонецЦикла;   

КонецПроцедуры


юлия_Maltseva250795

Oscar, Теперь пишет Индекс находится за границами массива

Теги:

Похожие темы (2)

Рейтинг@Mail.ru Rambler's Top100

Поиск