Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 окт 2022, 08:54

Помогите исправить ошибку в 1С:Предприятие 8.3, учебная версия

Автор юлия_Maltseva250795, 29 мар 2022, 07:33

0 Пользователей и 1 гость просматривают эту тему.

юлия_Maltseva250795

Задание: Дана последовательность чисел, среди которых есть один нуль. Удалить этот элемент массива и вывести результатный массив. Ввод элементов массива организовать с помощью диалогового окна ВвестиЗначение, вывод результата с помощью функции Сообщить.
-----------------------------------
Мой код:
&НаКлиенте
Процедура Задача3(Команда)
   нМассив =  СтрРазделить(ВведитеЧислаЧерезПробел, " ");
    лкСообщение = "Нули не найдены!";
    Для каждого нЗначение Из нМассив Цикл
      Если Число(нЗначение) = 0 Тогда
         лкСообщение = нМассив.Удалить(нЗначение);
         Прервать;
      КонецЕсли;
   КонецЦикла;
   Сообщить(лкСообщение);
КонецПроцедуры
-------------------------------
Почему выдаёт ошибку: Обращение к процедуре объекта как к функции (Удалить)
         лкСообщение = нМассив.Удалить(нЗначение);

Oscar

юлия_Maltseva250795,
А зачем Вы сообщению присваивайте удаление элемента массива?

лкСообщение = нМассив.Удалить(нЗначение);

Просто напишите заместо этого
нМассив.Удалить(нЗначение);

юлия_Maltseva250795


Oscar

юлия_Maltseva250795,
А так?

&НаКлиенте
Процедура Задача3(Команда)
 
   нМассив =  СтрРазделить(ВведитеЧислаЧерезПробел, " ");
   лкСообщение = "Нули не найдены!";
   Для каждого нЗначение Из нМассив Цикл
     Если Число(нЗначение) = 0 Тогда
        нМассив.Удалить(нЗначение);
        лкСообщение = "Найден один ноль!";
        Прервать;
     КонецЕсли;
   КонецЦикла;
   Сообщить(лкСообщение);

   Для каждого нЗначение Из нМассив Цикл
     Сообщить(нЗначение + " ");
   КонецЦикла;

КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск