Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 03:45

Не работает созданная роль, почему?

Автор VID1234, 23 мар 2022, 15:18

0 Пользователей и 1 гость просматривают эту тему.

VID1234

Приветствую. В конфигураторе БГУ 2, создал роль, настроил как мне нужно (но даже и с полными правами пытался), но при попытке войти под пользователем с этой ролью, выходит ошибка: "Авторизация не выполнена. Работа системы будет завершена. Недостаточно прав для входа в программу. Обратитесь к администратору!". С параметром "ЗапуститьОбновлениеИнформационнойБазы" запускал, обработку из БСП запускал, но толку нет! Что может быть? Как сделать, чтобы роль начала работать!

Yotram

Не могу сказать про БГУ, но в БП для запуска программы пользователю надо добавлять "Базовые права". Это на уровне конфигурации, прописано в коде.
"Дай человеку рыбу, и ты накормишь его на один день, научи его рыбачить, и он будет сыт всю жизнь"

Оптимус

Цитата: Yotram от 24 мар 2022, 06:23Это на уровне конфигурации, прописано в коде
А не подскажите, как прописано?

Yotram

// Возвращает текст ошибки, если у текущего пользователя нет ни роли базовые права, ни ролей администратора.
// Регистрирует ошибку в журнале.
//
Функция ОшибкаНедостаточноПравДляВходаВПрограмму(РегистрироватьВЖурнале = Истина) Экспорт

Если РольДоступна(Метаданные.Роли.ПолныеПрава) Тогда // Не заменять на РолиДоступны.
Возврат "";
КонецЕсли;

Если Пользователи.ЭтоСеансВнешнегоПользователя() Тогда
ИмяРолиБазовыеПрава = Метаданные.Роли.БазовыеПраваВнешнихПользователейБСП.Имя;
Иначе
ИмяРолиБазовыеПрава = Метаданные.Роли.БазовыеПраваБСП.Имя;
КонецЕсли;

Если РольДоступна(ИмяРолиБазовыеПрава) Тогда // Не заменять на РолиДоступны.
Возврат "";
КонецЕсли;

Возврат КраткоеПредставлениеОшибкиАвторизацииПослеРегистрацииВЖурнале(
НСтр("ru = 'Недостаточно прав для входа в программу.
           |
           |Обратитесь к администратору.'"),
, РегистрироватьВЖурнале);

КонецФункции

"Дай человеку рыбу, и ты накормишь его на один день, научи его рыбачить, и он будет сыт всю жизнь"

Оптимус


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск