Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 окт 2022, 07:35

Как увеличить стоимость на 10% в 1С:Предприятие 8.3

Автор юлия_Maltseva250795, 23 мар 2022, 09:25

0 Пользователей и 1 гость просматривают эту тему.

юлия_Maltseva250795

Есть форма, где пользователь выбирает валюту(её курс автоматически появляется в поле "Курс" ) и пишет необходимое количество и если пользователь поставил галочку возле элемента "Покупка" и нажал на кнопку "Рассчитать", то стоимость увеличивается на 10%.

Ивашка

ну.. в команде пропиши код:
Если Объект.Покупка Тогда
Объект.Стоимость = ...*0.1
КонецЕсли

Oscar

юлия_Maltseva250795,
Примерно так:

Если Покупка Тогда
   Стоимость = Курс * Количество * 1,1;
КонецЕсли;

Oscar

Цитата: Ивашка от 23 мар 2022, 09:42ну.. в команде пропиши код:
Если Объект.Покупка Тогда
Объект.Стоимость = ...*0.1
КонецЕсли

У Вас стоимость будет отображать 10%, а нужно увеличить на 10%, поэтому умножить нужно на 1,1

DmitriyF

Цитата: Oscar от 23 мар 2022, 09:45
Цитата: Ивашка от 23 мар 2022, 09:42ну.. в команде пропиши код:
Если Объект.Покупка Тогда
Объект.Стоимость = ...*0.1
КонецЕсли

У Вас стоимость будет отображать 10%, а нужно увеличить на 10%, поэтому умножить нужно на 1,1
Примерно так
Объект.Стоимость = КакаяТоСуммаДляРасчета + КакаяТоСуммаДляРасчета * НужныйПроцент / 100
🙂☺️

юлия_Maltseva250795

Oscar, не получается выдаёт ошибку: Переменная не определена (Оъект)
   Объект.СтоимостьВРуб = <<?>>Оъект.Курс * Объект.количество * 1.1; (Проверка: Тонкий клиент

Oscar

Цитата: юлия_Maltseva250795 от 23 мар 2022, 11:02Oscar, не получается выдаёт ошибку: Переменная не определена (Оъект)
   Объект.СтоимостьВРуб = <<?>>Оъект.Курс * Объект.количество * 1.1; (Проверка: Тонкий клиент
Не Оъект.Курс, а Объект.Курс

юлия_Maltseva250795

Oscar, исправила, теперь выдаёт ошибку:  Поле объекта не обнаружено (Покупка)

Oscar

юлия_Maltseva250795,
Вышлите полностью Ваш код. Наверное у Вас написано

Если Покупка Тогда
.....

Тогда попробуйте
Если Объект.Покупка Тогда
.....

юлия_Maltseva250795

Oscar, &НаКлиенте
Процедура расчёт(Команда)
   Если Объект.Покупка Тогда
Объект.СтоимостьВРуб = Объект.Курс * Объект.Количество * 1.1;
КонецЕсли
КонецПроцедуры

Ещё хочу добавить еще то что наименование валюты и её курс хранятся в справочнике "Валюта"

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск