Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
03 дек 2022, 17:03

Rак сделать так, чтобы должность автоматически подставлялась в доверенность?

Автор Bestoff, 16 мар 2022, 13:26

0 Пользователей и 1 гость просматривают эту тему.

Bestoff

Добрый день!

Скажите, пожалуйста, как сделать так, чтобы должность автоматически подставлялась в доверенность на получение товаров?
Выбираю Физ лицо и хочется, чтобы поле Должность автоматически заполнялось.

1С:Предприятие 8.3 (8.3.20.1674)
1С:Комплексная автоматизация 2 (2.4.14.115)

Заранее спасибо!

Screenshot_32.jpg

Ивашка

Bestoff, Прримерно так:
&НаКлиенте
Процедура ФизЛицоПриИзменении(Элемент)
ТекСтрока = Элементы.ИмяВашегоТЧ.ТекущиеДанные;
ТекСтрока.Должность = ПолучитьДолжность(Объект.ФизЛицо, "Должность");
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьДолжность(Ссылка, ИмяРеквизита)
Возврат Ссылка[ИмяРеквизита]
КонецФункции

Bestoff

Цитата: Ивашка от 16 мар 2022, 13:42Bestoff, Прримерно так:
&НаКлиенте
Процедура ФизЛицоПриИзменении(Элемент)
ТекСтрока = Элементы.ИмяВашегоТЧ.ТекущиеДанные;
ТекСтрока.Должность = ПолучитьДолжность(Объект.ФизЛицо, "Должность");
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьДолжность(Ссылка, ИмяРеквизита)
Возврат Ссылка[ИмяРеквизита]
КонецФункции

А куда это вставлять? )

Ивашка


Оптимус


Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск