Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 окт 2022, 07:49

Не создается новый партнер

Автор maurita23, 15 мар 2022, 19:42

0 Пользователей и 1 гость просматривают эту тему.

maurita23

Добрый день. ERP 2.5.7.336.
При создании нового Партнера (после заполнения ИНН) выходит ошибка
Ошибка отображения типов:
Отсутствует отображение для типа '{http://v8.1c.ru/8.1/data/core}ValueTable';
{ОбщийМодуль.ПартнерыИКонтрагентыЛокализацияКлиент.Модуль(1266)}:      РезультатЗапуска = ПартнерыИКонтрагентыЛокализацияВызовСервера.ФоновоеЗаданиеДанныеПартнераПоИННЗапустить(Форма.ИНН,
{ОбщийМодуль.ПартнерыИКонтрагентыЛокализацияКлиент.Модуль(274)}:      ИННПриИзменении_ПомощникНового(Форма);
{Справочник.Партнеры.Форма.ПомощникНового.Форма(1139)}:   ПартнерыИКонтрагентыЛокализацияКлиент.ПроверитьИНН(ЭтотОбъект);

по причине:
Ошибка при вызове серверного метода.
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: ret   Форма: Элемент   Тип: {http://www.w3.org/2001/XMLSchema}anyType
по причине:
Ошибка преобразования данных XDTO:
НачалоСвойства: Value   Форма: Элемент   Тип: {http://www.w3.org/2001/XMLSchema}anyType
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа '{http://v8.1c.ru/8.1/data/core}ValueTable';

Код процедуры типовой. Вылетает в этом месте (Процедура ИННПриИзменении(Форма, РеквизитыКонтрагента))
 
РезультатЗапуска = ПартнерыИКонтрагентыЛокализацияВызовСервера.ФоновоеЗаданиеДанныеПартнераПоИННЗапустить(РеквизитыКонтрагента.ИНН,
                                                                                                     РеквизитыКонтрагента.ЮрФизЛицо,
                                                                                                     Форма.УникальныйИдентификатор,
                                                                                                     Форма.ФоновоеЗаданиеИдентификатор);
      


Вызывается этот код. В отладчике он проверен, РезультатЗапуска в конце процедуры заполнен нужными данными.
Функция ФоновоеЗаданиеДанныеПартнераПоИННЗапустить(ИНН, ЮрФизЛицо, УникальныйИдентификатор, ИдентификаторЗадания) Экспорт
   
   РезультатЗапуска = Новый Структура("ЗаданиеЗапущено, РеквизитыКонтрагента", Ложь, Неопределено);
   РезультатЗапуска.Вставить("ИдентификаторЗадания","");
   РезультатЗапуска.Вставить("АдресХранилища","");
   
   Если ТипЗнч(ИдентификаторЗадания) = Тип("УникальныйИдентификатор") Тогда
      Задание = ФоновыеЗадания.НайтиПоУникальномуИдентификатору(ИдентификаторЗадания);
      
      Если Задание <> Неопределено
         И Задание.Состояние = СостояниеФоновогоЗадания.Активно Тогда
         Задание.Отменить();
      КонецЕсли;
   КонецЕсли;
   
   ИнформацияОбОшибке = Неопределено;
   ПараметрыФормирования = Новый Структура;
   ПараметрыФормирования.Вставить("ИНН", ИНН);
   ПараметрыФормирования.Вставить("ЭтоЮридическоеЛицо", ОбщегоНазначенияУТКлиентСервер.ЭтоЮрЛицо(ЮрФизЛицо));
   
   Попытка
      РезультатФоновогоЗадания = ДлительныеОперации.ЗапуститьВыполнениеВФоне(
         УникальныйИдентификатор,
         "ПартнерыИКонтрагентыЛокализация.ДанныеКонтрагентаПоИННФоновоеЗадание",
         ПараметрыФормирования,
         НСтр("ru = 'Работа с контрагентами: получение реквизитов по ИНН.'"));
   Исключение
      ИнформацияОбОшибке = ИнформацияОбОшибке();
      Возврат РезультатЗапуска;
   КонецПопытки;
   
   РезультатЗапуска.ИдентификаторЗадания  = РезультатФоновогоЗадания.ИдентификаторЗадания;
   РезультатЗапуска.АдресХранилища        = РезультатФоновогоЗадания.АдресХранилища;
   
   Если РезультатФоновогоЗадания.ЗаданиеВыполнено Тогда
      РезультатЗапуска.РеквизитыКонтрагента = ПолучитьИзВременногоХранилища(РезультатФоновогоЗадания.АдресХранилища);
   Иначе
      РезультатЗапуска.ЗаданиеЗапущено      = Истина;
   КонецЕсли;
   
   ИсторияРеквизитовВСтруктуру(РезультатЗапуска.РеквизитыКонтрагента);
   
   Возврат РезультатЗапуска;
   
КонецФункции


Может кто-то знает что теперь делать, чтобы эта ошибка исчезла?

LexaK

Цитата: maurita23 от 15 мар 2022, 19:42Может кто-то знает что теперь делать, чтобы эта ошибка исчезла?
два варианта
1.Не передавать на тонкого Клиента таблицу значений! (это где то в коде нужно сделать исправление)
или
2.Запустите предприятие в режиме Толстый Клиент и все будет работать без всяких доработок!
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск