Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2022, 11:28

Вывод таблицы из 1с в Word

Автор GuumClub, 06 мар 2022, 23:11

0 Пользователей и 1 гость просматривают эту тему.

GuumClub

Доброго дня
Прошу помощи
Не получается вывести таблицу из 1с в word
Прикладываю код и фото

&НаКлиенте
Процедура Сформировать(Команда)
Серверная1();
КонецПроцедуры


&НаСервере
Процедура Серверная1()
Заявка=РеквизитФормыВЗначение("Объект").ПолучитьМакет("Заявка");
MSWord = Заявка.Получить();

Попытка
Документ = MSWord.Application.Documents(1);
Документ.Activate();
Замена = Документ.Content.Find;

Замена.Execute("<Nazvanie>", Ложь, Истина, Ложь, , , Истина, , Ложь,  Объект.Мероприятие);
Замена = Документ.Content.Find;
Замена.Execute("<Adress>", Ложь, Истина, Ложь, , , Истина, , Ложь,  Объект.Адресс);
Замена = Документ.Content.Find;
    Замена.Execute("<Date>", Ложь, Истина, Ложь, , , Истина, , Ложь, Объект.Дата1);
Замена = Документ.Content.Find;


      MSWord.Application.Visible = Истина;
MSWord.Activate();

Таблица = Документ.Tabels.Item(1);
НомерСтроки = 0;

Пока Объект.ТабДок.Следующий() Цикл

Row = Таблица.Rows.Add(Таблица.Rows(НомерСтроки+1));
Row.Cells(1).Range.Text = Объект.ТабДок.ИмяСтудента;
Row.Cells(2).Range.Text = Объект.ТабДок.ПолныхЛет;
Row.Cells(3).Range.Text = Объект.ТабДок.НомерТелефона;



НомерСтроки = НомерСтроки +1;
КонецЦикла;

Исключение
Сообщение = Новый СообщениеПользователю();
Сообщение.Текст = ОписаниеОшибки();
Сообщение.Сообщить();
MSWord.Application.Quit();
КонецПопытки;






КонецПроцедуры // Серверная()

Теги: #Помогите 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск