Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 ноя 2022, 19:14

Ссылка в модуле формы на документ на клиенте

Автор Vetall, 06 мар 2022, 17:07

0 Пользователей и 1 гость просматривают эту тему.

Vetall

Кто подскажет, вроде простая вещь. Процедура в модуле формы на клиенте вызывает серверную функцию в этом же модуле для получения ссылки связанного дока. возврат ссылка дока. А на клиенте не понятное что-то показывает ссылка но она не активна, без данных просто название, попробовал в конфе на учебной базе без бсп, там на клиенте все четко ссылка на клиенте активна разворачивается с плюсиком. скрин прилагаю.
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
   
    //Гусев 06.03.2022 Суть Печать счета фактуры из заказа клиента
   
    Если Команда.Имя = "ГруппаПечатьКомандаПечати3" Тогда
       
        НашОбъект = Объект;
       
        СтруктураСФ = ПолучитьДоговорПрокатаПоЗаказу(НашОбъект);
        Номер = СтруктураСФ["Номер"];
        Док = СтруктураСФ["Док"];
       
        УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Док);
       
    КонецЕсли;

    ////Гусев 06.03.2022
   
    УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);
   
КонецПроцедуры



&НаСервере
Функция ПолучитьДоговорПрокатаПоЗаказу(НашЗаказ)
   
    Список = Новый Соответствие;
    ДокМассив = Новый Массив;
    Документы.ЗаказКлиента.ПолучитьПодчиненныеДокументы(Объект.Ссылка, Список);
   
    АрендаДоки = Список["АрендаНоменклатуры"];
    Док = АрендаДоки.Получить(0);
    Возврат Док.Ссылка;
   
КонецФункции

DmitriyF

&НаСервере
Функция ПолучитьДоговорПрокатаПоЗаказу(НашЗаказ)
   
    Список = Новый Соответствие;
    ДокМассив = Новый Массив;
    Документы.ЗаказКлиента.ПолучитьПодчиненныеДокументы(Объект.Ссылка, Список);
   
    АрендаДоки = Список["АрендаНоменклатуры"];
    Док = АрендаДоки.Получить(0);
    Возврат Док.Ссылка;
   
КонецФункции
Вопрос, зачем передавать в НашЗаказ Объект, если его ни где не используешь в функции?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск