Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 окт 2022, 02:03

ошибка модуля

Автор Любовь T., 05 мар 2022, 16:15

0 Пользователей и 1 гость просматривают эту тему.

Любовь T.

{Справочник.Контрагенты.Форма.ФормаЭлемента.Форма(38,1)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
<<?>>КонецПроцедуры (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаЭлемента.Форма(38,1)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
<<?>>КонецПроцедуры (Проверка: Сервер)
{Справочник.Контрагенты.Форма.ФормаЭлемента.Форма(38,1)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
<<?>>КонецПроцедуры (Проверка: Тонкий клиент)
 
Подскажите в чем ошибка
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

  Если ЮридическоеФизическоеЛицо = ПредопределенноеЗначение("Перечисление.ЮридическоеФизическоеЛицо.ЮридическоЛицо.")Тогда
      
              
  Если СтрДлина(Объект.ИНН) <> 10 Тогда
      Сообщить ("ИНН для юридического лица 10 символов");
       Отказ = Истина;
  КонецЕсли;
   
  Если СтрДлина(Объект.КПП) <> 9 Тогда
      Сообщить ("КПП Для юридического лица 9 символов");
       Отказ = Истина;
  КонецЕсли;   
   
  Если ЮридическоеФизическоеЛицо = ПредопределенноеЗначение("Перечисление.ЮридическоеФизическоеЛицо.ФизическоЛицо.")Тогда       
    
  Если СтрДлина(Объект.ИНН) <> 12 Тогда         
      Сообщить ("ИНН Для Физического лица 12 символов");
      Отказ = Истина;   
  КонецЕсли;      
                           
  Если  СтрДлина(Объект.КПП) <> 0 Тогда          
      Сообщить ("Для Физического лица КПП не заполняется");
      Отказ = Истина;
  КонецЕсли;   
      
      
КонецПроцедуры


LexaK

Любовь T., так вроде по русски пишет ошибку
нет оператора КонецЕсли;

у вас вот эти проверки - не дописаны
  Если ЮридическоеФизическоеЛицо = ПредопределенноеЗначение("Перечисление.ЮридическоеФизическоеЛицо.ЮридическоЛицо.")Тогда

попробуйте такой код
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

  Если ЮридическоеФизическоеЛицо = ПредопределенноеЗначение("Перечисление.ЮридическоеФизическоеЛицо.ЮридическоЛицо.")Тогда
             
  Если СтрДлина(Объект.ИНН) <> 10 Тогда
      Сообщить ("ИНН для юридического лица 10 символов");
       Отказ = Истина;
  КонецЕсли;
   
  Если СтрДлина(Объект.КПП) <> 9 Тогда
      Сообщить ("КПП Для юридического лица 9 символов");
       Отказ = Истина;
  КонецЕсли;   
   
  ИначеЕсли ЮридическоеФизическоеЛицо = ПредопределенноеЗначение("Перечисление.ЮридическоеФизическоеЛицо.ФизическоЛицо.")Тогда       
   
  Если СтрДлина(Объект.ИНН) <> 12 Тогда         
      Сообщить ("ИНН Для Физического лица 12 символов");
      Отказ = Истина;   
  КонецЕсли;     
                           
  Если  СтрДлина(Объект.КПП) <> 0 Тогда         
      Сообщить ("Для Физического лица КПП не заполняется");
      Отказ = Истина;
  КонецЕсли;   
 
  КонецЕсли;   
     
     
КонецПроцедуры
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск