Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 окт 2022, 00:54

На тонком клиенте у пользователя не заполняется табличная часть, в толстом норма

Автор VID1234, 03 мар 2022, 11:47

0 Пользователей и 1 гость просматривают эту тему.

VID1234

Здравствуйте. Есть код ниже, но он не работает если тонкий клиент! Почему, подскажите пожалуйста?
&НаКлиенте
Процедура ПоставкаСЗИТоварПриИзменении(Элемент)
    ОСТЧ = Элементы.ПоставкаСЗИ.ТекущиеДанные;
    Если Не ЗначениеЗаполнено(ОСТЧ.ТипЦены) Тогда
        Сообщить("Сначала заполните тип цены! После этого перевыберите товар, необходимые поля заполнятся автоматически!");
    Иначе
        Данные = ЦенаОС(Объект.Дата, ОСТЧ.Товар, ОСТЧ.ТипЦены);
       
        //Для Каждого Пункта Из Данные Цикл
        //    ОСТЧ.Цена = Пункта.Цена;
        //    ОСТЧ.Описание = Пункта.Описание;
        //КонецЦикла;
       
    КонецЕсли;
КонецПроцедуры

&НаСервере
Функция ЦенаОС (Дата, Номенклатура, ТипЦены)
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ЦеныНоменклатурыСрезПоследних.Цена КАК Цена,
        |    ЦеныНоменклатурыСрезПоследних.Описание КАК Описание,
        |    ЦеныНоменклатурыСрезПоследних.ТипЦены КАК ТипЦены,
        |    ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Товар
        |ИЗ
        |    РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&Период, ) КАК ЦеныНоменклатурыСрезПоследних
        |ГДЕ
        |    ЦеныНоменклатурыСрезПоследних.ТипЦены = &ТипЦены
        |    И ЦеныНоменклатурыСрезПоследних.Номенклатура = &Номенклатура";
   
    Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
    Запрос.УстановитьПараметр("Период", Дата);
    Запрос.УстановитьПараметр("ТипЦены", ТипЦены);
   
    РезультатЗапроса = Запрос.Выполнить();
   
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выгрузить();
     Объект.ПоставкаСЗИ.Загрузить(ВыборкаДетальныеЗаписи);   
   
Возврат ВыборкаДетальныеЗаписи;
КонецФункции

VID1234


LexaK

VID1234, нельзя в тонком клиенте возвращать с Сервера ТаблицуЗначений

вот эту команду
Возврат ВыборкаДетальныеЗаписи;
уберите или переделайте
если помогло нажмите: Спасибо!

VID1234


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск