Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2022, 11:46

Позиционирование на нужном поле строки Дерева в зависимости от строки Списка

Автор oooo800, 22 фев 2022, 11:02

0 Пользователей и 1 гость просматривают эту тему.

oooo800

Платформа 8..3.19.1467, самописная конфигурация, УФ.
Справочник - "Номенклатура";форма списка с элементами "Дерево" и "Список"
Нужно чтобы при позиционировании на группе в "Список" у которой нет родителя (по сути - родитель корневой узел) в "Дерево" было позиционирование на эту же строку, И на определенном поле (столбец), например "Код".

Для этого в "Список" в событии
"ПриАктивизацииСтроки" делаем
Если Элемент.ТекущиеДанные <> Неопределено Тогда
Если ЗначениеЗаполнено(Элемент.ТекущиеДанные.ЭтоГруппа) = Истина Тогда
ТекущаяСтрока = Элемент.ТекущаяСтрока;
Элементы.Дерево.ТекущаяСтрока = ТекущаяСтрока;
Иначе
КонецЕсли;
КонецЕсли;

Позиционирование в "Дерево" на строке производится.
Но как в этой строке принудительно спозиционироваться на поле "Код" ?


LexaK

oooo800, надо обрабатывать такое событие, пример
&НаКлиенте
Процедура СписокПриАктивизацииПоля(Элемент)
Элементы.Список.ТекущийЭлемент = Элементы.Код;
КонецПроцедуры

вот именно при обработке этого события срабатывает
ответ Понравился? (в смысле пригодился?)

oooo800

LexaK, мне надо спозиционироваться в "Дерево" на той же самой строке что и в "Список" , и на поле код строки "Дерево" .

LexaK

oooo800, а что в примере не понятно?

(подсказка) вам надо подставить свои наименования элементов
(кто же их, кроме вас знает?)
ответ Понравился? (в смысле пригодился?)

oooo800

Они были указаны в вопросе - "Список" и "Дерево" .
Просто, Ваш ответ трактовал, как позиционирование в поле текущей строки "Список" по событию ПриАктивизацииСтроки в "Список" же.

LexaK

oooo800,
Цитироватьпо событию ПриАктивизацииСтроки в
ээээ, невнимательно читаем ответы!
надо обрабатывать событие: ПриАктивизацииПоля() ! 
ответ Понравился? (в смысле пригодился?)

oooo800

Цитата: LexaK от 22 фев 2022, 15:55oooo800,
Цитироватьпо событию ПриАктивизацииСтроки в
ээээ, невнимательно читаем ответы!
надо обрабатывать событие: ПриАктивизацииПоля() ! 

Это очепЯтка.
Да, ПриАктивизацииПоля.
Хотя было бы лучше, если бы по полю надписи срабатывало бы событие "Нажатие" и без гиперссылка.
Но оно не работает.

oooo800

А как быть, если меняется строка - событие ПриАктивизацииЯчейки ?

LexaK

ответ Понравился? (в смысле пригодился?)

oooo800

Цитата: LexaK от 24 фев 2022, 10:10а вообще, зачем все это?
Для логичной (с моей точки зрения) отработки в связке на одной форме "Дерево" и "Список" .
Причем, почти сделал, правда. через костыли, но осталась пара моментов довести ...
Есть возможность донести разработчикам платформы пожелания по доделке функционала "Дерево" и "Список" ?


Цитата: Oksy78 от 24 фев 2022, 11:42Раньше обращалась за помощью в разные компании, но везде происходили какие-то затыки и непонимания (то сроки, то медленная скорость ответов). Нашла случайно в интернете  AMK-Group https://amk.expert/ , оказались грамотные ребята, помогли с вопросом любой сложности, причём очень быстро. Оказалось на рынке больше 30 лет, но раньше с ними не работала, хотя знаю многих. Рекомендую
Это бесплатно ?

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск