Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2022, 10:50

Не сохраняется картинка!

Автор Алексей_1985_06, 19 фев 2022, 18:15

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Ребят подскажите где поправить код?
1. Есть реквизит формы "АдресКартинки" - сюда помещается файл во временное хранилище.
2. Реквизит объекта "ДанныеКартинки" -  хранилище значений

Если закрыть форму "нажатие на крестик" и подтвердить изменение данным - то все сохраняется, а вот если нажать на кнопку "ЗаписатьИЗакрыть" - то при повторном открытии картинка не отображается!
Знатоков прошу подсказать в чем дело?

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
   
   Если  ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
ТекущийОбъект.ДанныеКартинки = Новый ХранилищеЗначения (ПолучитьИзВременногоХранилища(АдресКартинки));
КонецЕсли;

КонецПроцедуры

[/code]&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   
   Если Объект.Ссылка.Пустая() Тогда
      Возврат
   КонецЕсли;
   
   АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеКартинки");
   
КонецПроцедуры[/code]



Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск