Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 окт 2022, 00:53

Поиск реквизитов на форме по элементу формы

Автор nordri, 18 фев 2022, 20:57

0 Пользователей и 1 гость просматривают эту тему.

nordri

При попытке разобраться с другим вопросом, изобрел велосипед:

&НаСервере
Функция  НайтиВозможныйРеквизитформыНаСервере(ИскомыйЭлементНаСервере)
Если Не ИскомыйЭлементНаСервере="" Тогда
Для Каждого Рек из ЭтаФорма.Элементы  Цикл
Если рек.Имя=ИскомыйЭлементНаСервере
Или Рек.Заголовок=ИскомыйЭлементНаСервере
Тогда
Возврат рек.ПутьКДанным;
КонецЕсли;
КонецЦикла;
КонецЕсли;
Возврат Истина;
КонецФункции  //НайтиЭлементыНаСервере

&НаКлиенте
Процедура НайтиРеквизит(Команда)
ИмяОбъекта = НайтиВозможныйРеквизитформыНаСервере(ЭлементДляПоиска);
Если ИмяОбъекта=Истина Тогда
Предупреждение("Не найдено");
Иначе
ЭтотОбъект[ИмяОбъекта]=НовоеЗначение;
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
ЭлементДляПоиска="Реквизит1"; НовоеЗначение="Текст нового значения";
КонецПроцедуры
Позволяет найти нужный реквизит, используя обработчик события, например:
Регулирование(Элемент, Направление, СтандартнаяОбработка)А точнее: Элемент.Имя

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск