Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2022, 11:00

Расширение для Печати этикеток

Автор 2andr, 14 фев 2022, 10:47

0 Пользователей и 1 гость просматривают эту тему.

2andr

Всем доброго дня.
Конфигурация УНФ проф, платформа 8.3.19

Встала задача - печатать этикетки на товары из "заказ покупателя" с номером и датой отгрузки заказа.

Стандартная печать этикеток из заказа покупателя не содержит ссылки на документ.

Но в конфигурации есть форма ПечатьЭтикеток
В которой присутствует ссылка на документ.

Кто подскажет с помощью расширения возможно добавить возможность использовать форму ПечатьЭтикеток?

LexaK

кроме расширения, еще есть вариант использовать ВПФ (внешнюю печатную форму) подключается через БСП, в кнопке списке печатных форм документа Заказа, появится ваша новая ПФ этикеток с доработками.
ответ Понравился? (в смысле пригодился?)

2andr

LexaK, спасибо.
А при ВПФ передаётся ссылка на документ из которого вызвана форма?

LexaK

да, конечно! и при печати из списка документов, если выделите несколько строчек документов, передаются как массив.
наверняка у вас с базе уже есть ВПФ, возьмите как за пример.
ответ Понравился? (в смысле пригодился?)

2andr

Всеже спрошу:
В конфигурации УНФ есть штатная обработка "ПечатьЭтикетокИЦенников"
В ней есть реквизит "ПечатьИзДокумента"
Есть Процедура
&НаСервере
Процедура УстановитьВидимостьПечатьИзДокумента()

А в формеПечати этой обработки есть Группа которая меняет видимость в зависимости от
  Если Не Объект.ПечатьИзДокумента Тогда
    Возврат;
  КонецЕсли;

Но при вызове штатной кнопкой "Печать этикеток" из Формы ЗаказПокупателя
Группа "ПечатьИзДокумента" остается невидимой в форме ПечатьЭтикетокИЦенников

Теперь вопрос: По всей видимости "Объект.ПечатьИзДокумента" пустой при отправке из Заказ Покупателя
Как добавить этот Реквизит при отправке из ЗаказПокупателя - с помощью расширения ?

2andr


2andr

Вот Модуль этой формы

2andr

Появилось время....
Итак В расширение добавил "Обработки > ПечатьЭтикетокИЦенников > Формы > Форма"
И в Модуле формы расширения перезадал процедуру

&Вместо("ПриСозданииНаСервере")

изменил лишь две строчки

Было
      Если СтруктураДанных.СтруктураДействий.Свойство("ПоказыватьКолонкуКоличествоВДокументе", ПараметрДействия) Тогда
        Элементы.ТоварыКоличествоВДокументе.Видимость = ПараметрДействия;
      КонецЕсли;
     
      Если СтруктураДанных.СтруктураДействий.Свойство("УстановитьРежимПечатиИзДокумента", ПараметрДействия) Тогда
        Объект.ПечатьИзДокумента = ПараметрДействия;
      КонецЕсли;

      Если СтруктураДанных.СтруктураДействий.Свойство("ПоказыватьКолонкуКоличествоВДокументе", ПараметрДействия) Тогда
        Элементы.ТоварыКоличествоВДокументе.Видимость = Истина;
      КонецЕсли;
     
      Если СтруктураДанных.СтруктураДействий.Свойство("УстановитьРежимПечатиИзДокумента", ПараметрДействия) Тогда
        Объект.ПечатьИзДокумента = Истина;
      КонецЕсли;

Тоесть принудительно включил видимость элементов

В результате в форме появились оба поля, и с правильными значениями....

2andr

То есть в структуре данных
Свойство "УстановитьРежимПечатиИзДокумента"
Установлено в Ложь

Хотя идёт печать из документа.....

А как найти где устанавливается это свойство?

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск