Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 окт 2022, 00:35

Ошибка "Каталог не обнаружен" после помещения файла во временное хранилище

Автор alexey980, 10 фев 2022, 11:22

0 Пользователей и 1 гость просматривают эту тему.

alexey980

Для ускорения процесса правки и тестирования внешнего отчета в режиме отладки под толстым клиентом на управляемых формах я хочу добавить функционал "переоткрытия" отчета - грубо говоря, повесить на основную форму отчета кнопку, при нажатии на которую будет выполняться команда, закрывающая отчет и открывающая его заново. Код модуля формы отчета приводится ниже.

Это нужно лишь для того, чтобы при редактировании внешнего отчета в процессе отладки (в том числе при изменении содержимого процедуры модуля отчета ПриКомпоновкеРезультата) не нужно было затем вручную закрывать и открывать его заново, чтобы отобразились изменения, а сделать это в один клик по нажатию кнопки  переоткрытия (или еще быстрее - с использованием назначенного ей сочетания клавиш).

Вопрос в том, что при сохранении новой версии отчета после внесения изменений в отчет и вызове обработчика команды "ПереоткрытьОтчет" выскакивает ошибка типа "Каталог не обнаружен 'e1cib\tempstorage\698e1b83-889a-4733-8d05-507b3b1f6646'. 3(0x00000003): Системе не удается найти указанный путь".

Есть идеи, как это можно исправить?

// в модуле основной формы отчета

&НаКлиенте
Процедура ПереоткрытьОтчет(Команда)   

АдресХранилища = "";
ПоместитьФайл(АдресХранилища, ИмяФайлаВнешнегоОтчета(), , Ложь);
ПодключитьВнешнийОтчет(АдресХранилища);

НоваяФорма = ПолучитьФорму(ЭтаФорма.ИмяФормы,,,Истина);
НоваяФорма.Открыть();
ЭтаФорма.Закрыть();

КонецПроцедуры

&НаСервере
Функция ИмяФайлаВнешнегоОтчета()
Возврат РеквизитФормыВЗначение("Отчет").ЭтотОбъект.ИспользуемоеИмяФайла;
КонецФункции

&НаСервере
Функция ПодключитьВнешнийОтчет(АдресХранилища)
Возврат ВнешниеОтчеты.Подключить(АдресХранилища, , Ложь);
КонецФункции

Ванин на Оби

Цитата: alexey980 от 10 фев 2022, 11:22Есть идеи, как это можно исправить?
Создать под толстого клиента отдельного пользователя и не заморачиваться с пере-открытием и перезакрыванием
НАЙДЕННЫЕ  волонтёрами нашей группы (Ванин -  Елена) пропавшие в Украине люди https://forum-1c.ru/index.php?topic=79555.0

alexey980

Цитата: Геннадий на Оби от 10 фев 2022, 11:57Создать под толстого клиента отдельного пользователя и не заморачиваться с пере-открытием и перезакрыванием
Не понимаю, о чем это вы.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск