Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 мая 2022, 19:00

использование в табличной части тип данных перечисление

Автор konst2022, 09 фев 2022, 11:41

0 Пользователей и 1 гость просматривают эту тему.

konst2022

Не получается использовать тип данных перечисления
Screenshot_18.png
[img]https://pastenow.ru/908b4f8a4aecc519327d5d1c984570c1[/img]
&НаКлиенте
Процедура ТабличнаяЧасть1КоличестворезокПриИзменении(Элемент)


   Для Каждого ТабличнаяЧасть1 Из Объект.ТабличнаяЧасть1 Цикл
   
   
   Если ТабличнаяЧасть1.Видрезки="Ангар" Тогда
   
  ТабличнаяЧасть1.Суммарезки="14" ;
Иначе
ПоказатьОповещениеПользователя("Не работает");
 
КонецЕсли;

КонецЦикла;
КонецПроцедуры
Прииспользовании процедуры ничего не выводит:
[img]https://pastenow.ru/b53f861a3a4f567fe07d09d2b2c980cb[/img]
Прииспользовании процедуры ничего не выводит:




antoneus

Если ТабличнаяЧасть1.Видрезки = ПредопределенноеЗначение("Перечисление.ВидыРезки.Ангар") Тогда

konst2022


antoneus

И урок на будущее - перечисление, элемент справочника, документ - не то же самое, что строка!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск