Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 23:44

Получить значение

Автор Алексей_1985_06, 07 фев 2022, 22:07

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Есть справочник АдминистративноТерриториальныеЕдиницы стандартный реквизит Наименование и реквизит СокращенноеНаименование
в РС есть реквизит с типом СправочникСсылка.АдминистративноТерриториальныеЕдиницы, как получить значение реквизита СокращенноеНаименование ? через точку не получается....

&НаКлиенте
Процедура АдминистративноТерриториальныеЕдиницыПриИзменении(Элемент)

Сообщить (Запись.АдминистративноТерриториальныеЕдиницы.СокращенноеНаименование);

КонецПроцедуры

antoneus

На клиенте через точку и не получится, надо на сервере доставать.

Алексей_1985_06

antoneus, можете подсказать, как лучше реализовать заполнение адреса, при изменении реквизитов (например: дом, корпус и т.д) должен формироваться полный адрес, подставляя сокращенное название (например: дом, как д.) Я создал справочник с полным названием и сокращенным, выходит что необходимо при выборе получать сокращенное название, что каждый раз Сервер нужно дергать?

LexaK

Алексей_1985_06,
Цитироватьчто каждый раз Сервер нужно дергать?

так сервер и так "дергается" 1000000 (миллион) раз в секунду, плюс десяток ваших вызовов погоды не сделают
вот самый простой способ получения значения реквизита какого либо объекта,
можете оформить в общем модуле, что из разным мест, форм, можно было вызывать эту функцию


&НаКлиенте
Процедура АдминистративноТерриториальныеЕдиницыПриИзменении(Элемент)
   
    //Сообщить (Запись.АдминистративноТерриториальныеЕдиницы.СокращенноеНаименование);
    Сообщить (ЗначениеРеквизита(Запись.АдминистративноТерриториальныеЕдиницы, "СокращенноеНаименование"));
   
КонецПроцедуры

&НаСервереБезКонтекста
Функция ЗначениеРеквизита(Объект, ИмяРеквизита)
//Объект - любая ссылка или коллекция
//ИмяРеквизита - имя реквизита
 
лкЗначение = Неопределено;//инициализация
Попытка
лкЗначение = Объект[ИмяРеквизита];//получение значения
Исключение
лкОшибка = ОписаниеОшибки();//если неправильно было задано Имя
ВызватьИсключение лкОшибка;
КонецПопытки;

Возврат лкЗначение;

КонецФункции
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск