Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 сен 2022, 20:57

Создание поле формы

Автор ef0din, 01 фев 2022, 11:39

0 Пользователей и 1 гость просматривают эту тему.

ef0din

Добрый день! Есть УХ 3.1.12.9. Платформа 8.3.17.1989.

Есть форма оперативного плана. Оттуда выбирается статья движения денежных средств. При этом открывается формы выбора статьи движения денежных средств. При открытии программно формируются некоторые поля формы. Формирование происходит в общем модуле "ФормыУХ", в функцие:

Функция СоздатьПолеФормы(Элементы, Имя, Заголовок = "", ПутьКДанным, Вид = Неопределено, Родитель, ВставитьПередЭлементом = Неопределено, ПараметрыЭлемента = Неопределено, СобытияЭлемента = Неопределено) Экспорт

НайденноеПоле = Элементы.Найти(Имя);
Если НайденноеПоле <> неопределено Тогда
Поле = НайденноеПоле;
ИначеЕсли ВставитьПередЭлементом = Неопределено Тогда
Поле = Элементы.Добавить(Имя, Тип("ПолеФормы"), Родитель);
Поле.ПутьКДанным = ПутьКДанным;
Иначе
Поле = Элементы.Вставить(Имя, Тип("ПолеФормы"), Родитель, ВставитьПередЭлементом);
Поле.ПутьКДанным = ПутьКДанным;
КонецЕсли;

Если Вид = Неопределено Тогда
Поле.Вид = ВидПоляФормы.ПолеВвода;
Иначе
Поле.Вид = Вид;
КонецЕсли;

Поле.Заголовок = Заголовок;

Если ТипЗнч(ПараметрыЭлемента) = Тип("Структура") Тогда
ЗаполнитьЗначенияСвойств(Поле, ПараметрыЭлемента);
ИначеЕсли Поле.Вид = ВидПоляФормы.ПолеВвода Тогда
ЗаполнитьЗначенияСвойств(Поле, ПараметрыПоляВводаПоУмолчанию());
ИначеЕсли Поле.Вид = ВидПоляФормы.ПолеФлажка Тогда
ЗаполнитьЗначенияСвойств(Поле, ПараметрыПоляФлажкаПоУмолчанию());
КонецЕсли;

Если ТипЗнч(СобытияЭлемента) = Тип("Структура") Тогда
Для Каждого КлючЗначение Из СобытияЭлемента Цикл
Поле.УстановитьДействие(КлючЗначение.Ключ, КлючЗначение.Значение);
КонецЦикла;
КонецЕсли;

Возврат Поле;

КонецФункции



В моем случае дохожу до
Поле = Элементы.Вставить(Имя, Тип("ПолеФормы"), Родитель, ВставитьПередЭлементом);
Поле.ПутьКДанным = ПутьКДанным;

И там, где идет присвоение "ПутьКДанным" ругается: "Недопустимое значение, Поле.ПутьКДанным = ПутьКДанным;"

В переменной "ПутьКДанными" прописано реквизит динамического списка.

Опытным путем обнаружили, что проблема возникает именно в случае, когда реквизит дин. списка пытаемся в путьКДанным подставить. Что теперь правда с этим делать - неясно. Не хочется пол типовой формы переписывать. Мб есть у кого идеи, или кто сталкивался - прошу подсказать.

Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск