Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 23:10

автозаполнение элемента формы документа из справочника при выборе группы

Автор Mazerr, 23 янв 2022, 09:44

0 Пользователей и 1 гость просматривают эту тему.

Mazerr

 Ребят, помогите, в документе при выборе группы, надо, чтобы автоматически заполнялся список студентов из справочника.
Документ называется : "выставление оценок", Справочник называется :"Студенты".   
В документе у меня в реквизитах :Группа;Предмет; в табличной части: Студент; Оценка;
В справочнике студенты: Фамилия; Имя; Отчество; Группа

Геннадий на Оби


Mazerr

Геннадий на Оби, Я вообще только начал этим заниматься, поэтому посидел, почитал форумы, но так ничего и не нашел, так что по факту ничего толкового не сделал

Ивашка

Mazerr, примерно так:
&НаСервере
Процедура ГруппаПриИзмененииНаСервере()

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Студенты.Ссылка КАК Ссылка
|ИЗ
| Справочник.Студенты КАК Студенты
|ГДЕ
| Студенты.группа = &группа";

Запрос.УстановитьПараметр("группа", Объект.Группа);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Объект.СписокСтудентов.Очистить();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
НовСтрока = Объект.СписокСтудентов.Добавить();
НовСтрока.Студент = ВыборкаДетальныеЗаписи.Ссылка;
КонецЦикла;


КонецПроцедуры

&НаКлиенте
Процедура ГруппаПриИзменении(Элемент)
ГруппаПриИзмененииНаСервере();
КонецПроцедуры

Mazerr

Ивашка, Почти получилось, единственное теперь не заполняется фио, но создаются строки с ровными количеством человек из группы
Дополняю: Немного ошибся в коде, сейчас исправил и все заработало!!!! Ура, Спасибо огромное!!!)))

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск