Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 23:18

Почему документ не делает движения по регистру бухгалтерии?

Автор VID1234, 14 янв 2022, 12:55

0 Пользователей и 1 гость просматривают эту тему.

VID1234

Здравствуйте в БГУ 2.0.82.16, есть такой код:
Движения.ЖурналПроводокЕПСБУ.Записывать = Истина;
    Движения.ЖурналПроводокЕПСБУ.Очистить();
   
    Для Каждого ТекСтрокаВидыЗатрат Из ВидыЗатрат Цикл
       
        Движение = Движения.ЖурналПроводокЕПСБУ.Добавить();
        Движение.Регистратор = ЭтотОбъект.Ссылка;
        Движение.ИФО = ЭтотОбъект.Баланс;
        Движение.Период     = ЭтотОбъект.Дата;               
        Движение.Организация = Организация;
        Движение.КФО        = Перечисления.КВД.Внебюджет;
       
        //Дт 106 Кт 109
        Если ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ВводОстатковПоСтарым Тогда
            Движение.Содержание = "Ввод остатков по старым ";
        //Дт 109 Кт 106   
        ИначеЕсли ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ЗакрытиеСПлюсом Тогда
            Движение.Содержание = "Закрытие внутреннего  с положительным результатом";
        //Дт 401 Кт 106   
        Иначе
            Движение.Содержание = "Закрытие внутреннего  с отрицательным результатом";
        КонецЕсли;
       
        Движение.СчетДт = ТекСтрокаВидыЗатрат.СчетДебета;
        Движение.КПСДт = ТекСтрокаВидыЗатрат.КБКСчетДебета;
        Движение.КЭКДт         = ТекСтрокаВидыЗатрат.КОСГУСчетДебета;
       
        Если ТекСтрокаВидыЗатрат.СчетДебета = ПланыСчетов.ЕПСБУ.НайтиПоКоду("109.61") или ТекСтрокаВидыЗатрат.СчетДебета = ПланыСчетов.ЕПСБУ.НайтиПоКоду("106.3И") Тогда
            Движение.СубконтоДт[планыВидовХарактеристик.ВидыСубконто.Номенклатура] = ТекСтрокаВидыЗатрат.СубконтоСчетДебета2;
            Движение.СубконтоДт[планыВидовХарактеристик.ВидыСубконто.ВидыЗатрат]    = ТекСтрокаВидыЗатрат.СубконтоСчетДебета3;
        КонецЕсли;
       
        //Движение.СубконтоДт.ВидыЗатрат    = ТекСтрокаВидыЗатрат.СубконтоСчетДебета3; нет у 401.10
       
        Движение.СчетКт = ТекСтрокаВидыЗатрат.СчетКредита;
        Движение.КПСКт  = ТекСтрокаВидыЗатрат.КБКСчетКредита;
        Движение.КЭКДт = ТекСтрокаВидыЗатрат.КОСГУСчетКредита;
       
        Если ТекСтрокаВидыЗатрат.СчетКредита = ПланыСчетов.ЕПСБУ.НайтиПоКоду("109.61") или ТекСтрокаВидыЗатрат.СчетКредита = ПланыСчетов.ЕПСБУ.НайтиПоКоду("106.3И") Тогда
            Движение.СубконтоКт.Номенклатура  = ТекСтрокаВидыЗатрат.СубконтоСчетКредита2;
            Движение.СубконтоКт.ВидыЗатрат    = ТекСтрокаВидыЗатрат.СубконтоСчетКредита3;
        КонецЕсли;
   
        Движение.Сумма = ТекСтрокаВидыЗатрат.Сумма;
       
        //НУ
        Если ФормироватьПроводкиПоНУ Тогда
           
            Если ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетДебетаНУ) или ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетКредитаНУ) Тогда
               
                Движение = Движения.ЖурналПроводокЕПСБУ.Добавить();
                Движение.Период     = Дата;               
                Движение.Организация = Организация;
                Движение.Сумма      = ТекСтрокаВидыЗатрат.Сумма;
               
                Если ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетДебетаНУ) Тогда
                    Движение.СчетДт = ТекСтрокаВидыЗатрат.СчетДебетаНУ;
                   
                    Если Лев(Движение.СчетДт.Код,2) = "Н2" Тогда
                        Если ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ВводОстатковПоСтарым Тогда
                            Движение.Содержание = "Ввод остатков по старым";
                            Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
                            Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
                           
                        ИначеЕсли ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ЗакрытиеСПлюсом Тогда
                            Движение.Содержание = "Закрытие внутреннего с положительным результатом";
                            Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
                            Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
                           
                        Иначе
                            Движение.Содержание = "Закрытие внутреннего с отрицательным результатом";
                            Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
                            Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
                        КонецЕсли;
                       
                    ИначеЕсли Лев(Движение.СчетДт.Код,2) = "НЕ" Тогда
                    Иначе
                        Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
                        Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
                       
                        //Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ1;
                        //Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ2;
                    КонецЕсли;
                   
                КонецЕсли;
               
                Если ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетКредитаНУ) Тогда
                    Движение.СчетКт = ТекСтрокаВидыЗатрат.СчетКредитаНУ;
                    Если Лев(Движение.СчетКт.Код,2) = "Н2" Тогда
                        Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ1;
                        Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ2;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;   
           
        КонецЕсли; //Если ФормироватьПроводкиПоНУ Тогда
       
    КонецЦикла;


По коду посмотрел, все заполняет, значение в движение подставляются, но в регистре бухгалтерии данные не появляются! Я смотрю через кнопку ДТКт, ну и вывел регистр в шапку, туда прохожу, там тоже пусто.
Через конструктор пробовал, аналогично!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск