Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 23:24

Передача данных с одной формы на другую

Автор Buktoria, 06 янв 2022, 12:20

0 Пользователей и 1 гость просматривают эту тему.

Buktoria

Здравствуйте, может найдутся добрые люди, которые смогут объяснить новичку, как сделать передачу данных с одной формы на другую
Для примера можем взять Справочник Книги с реквизитом Наименование
И Документ Выдача Книг с реквизитами Книга и Дата Возврата, как передать наименование книги из формы справочника в форму документа в строку Книга
Помогите пожалуйста понять, буду очень благодарна)

alexandr_ll

Buktoria, Какой тип значения у реквизита "Книга" в  документе?

Buktoria


Алексей_1985_06

Buktoria, Используйте параметры формы!
Для примера:
https://www.1s-up.ru/otkrytie-formy-v-1s-8-3-s-peredachej-parametrov-na-primere/

alexandr_ll

Buktoria, Так у вас при выборе реквизита "Книга" разве не появляется его наименование?

Алексей_1985_06

Цитата: alexandr_ll от 06 янв 2022, 13:24Buktoria, Так у вас при выборе реквизита "Книга" разве не появляется его наименование?
Наверное нужно из формы справочника открыть форму документа, так?
Если да то вот пример с передачей параметры из одной формы в другую, подставьте только свои данные:

// В месте вызова.
// Формируем параметр формы.
Параметры = Новый Структура();
Параметры.Вставить("Важность", ПредопределенноеЗначение("Перечисление.Важность.Важно"));
// Открываем форму с указанием параметров.
ОткрытьФорму("ОбщаяФорма.ФормаПросмотра", Параметры);
...
// В модуле формы.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
 Если Параметры.Важность = Перечисления.Важность.Важно Тогда
 ...
 КонецЕсли;
КонецПроцедуры

Buktoria

alexandr_ll, нужно чтобы при переходе с формы справочника где хранятся названия книг, на форму документа Выдача книг, в строке сразу отображались выбранная книга

Buktoria

На форме справочника создала команду для открытия формы документа

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыпоненияКоманды)
ПараметрыФормы = Новый Структура ("МассивКниг", ПараметрыКоманды) ;
ОткрытьФорму("Документ.ВыдачаКниг.ФормаОбъекта", ПараметрыФормы, ПараметрВыпоненияКоманды.Источник,ПараметрВыпоненияКоманды.Уникальность,ПараметрВыпоненияКоманды.Окно);

КонецПроцедуры

Форма открывается

а вот что и куда дальше записывать не могу разобраться

Buktoria

Если попробовать так?

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, Стандартная Обработка)
Если ЗначениеЗаполнено(ЭтаФорма.Параметры.МассивКниг) Тогда

.... (сюда не понимаю, что писать, так как нашла пример с таб частью, а у меня просто реквизит)

КонецЕсли;
КонецПроцедуры

Buktoria


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск