Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
03 дек 2022, 17:02

Диалог Выбора Файла

Автор Lopol, 17 дек 2021, 10:14

0 Пользователей и 1 гость просматривают эту тему.

Lopol

Приветствую!
Уважаемые, помогите пожалуйста разобраться в ошибке, два дня не получается уже!
Процедура ПолучитьСтрокуДанныхИзФайла (СтрокаДанных) Экспорт

Проводник=Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
   Если Проводник.Выбрать() = Ложь Тогда
   Возврат;
   КонецЕсли; 
   
   Текст=Новый ТекстовыйДокумент;
   Текст.Прочитать(Проводник.ПолноеИмяФайла);
   СтрокаДанных=Текст.ПолучитьТекст();
КонецПроцедуры

ошибка:
{CommonModule.РаботаСТаблицей.Module(3,17)}: Тип не определен (ДиалогВыбораФайла)

Помогите пожалуйста

LexaK

Lopol, примерно такой код должен быть (обычные формы)
Длг = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);

Длг.ПолноеИмяФайла = мИмяФайла;
Длг.Каталог = мИмяПути;
Длг.Заголовок = "Выберите файл со списком запросов";
Длг.Фильтр = "Файлы запросов (*.sel)|*.sel|Все файлы (*.*)|*.*";
Длг.Расширение = "sel";

Если Длг.Выбрать() Тогда
мИмяФайла = Длг.ПолноеИмяФайла;
мИмяПути = Длг.Каталог;
ЗагрузитьЗапросыИзФайла();
СохранитьИмяФайла();
УстановитьЗаголовокФормы();
КонецЕсли;
если помогло нажмите: Спасибо!

wise

(0) &НаКлиенте
когда НЕ указано, то ЗНАЧИТ &НаСервере
а на сервере платформа НЕ знает ТАКОГО...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

LexaK

wise, эээ, а как же Толстый клиент? (многие команды и типы доступны и На Сервере и в Толстом клиенте)

хорошо было бы если автор темы указал какие формы, платформа, ...
если помогло нажмите: Спасибо!

Lopol


Теги: помощь 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск