Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 10:35

Ошибка в листинге Функции модуля объекта документа (1С 8.3)

Автор Дудков Дмитрий, 05 дек 2021, 17:14

0 Пользователей и 1 гость просматривают эту тему.

Дудков Дмитрий

Написал функцию перед обработкой проведения в модуле документа вставив её перед процедурой ОбработкаПроведения, но получаю ошибку:

Документ.ФормированиеБригады.МодульОбъекта(17,9)}: Оператор Возврат (Return) не может употребляться вне процедуры или функции
Возврат <<?>>Истина; (Проверка: Сервер)
{Документ.ФормированиеБригады.МодульОбъекта(20,9)}: Оператор Возврат (Return) не может употребляться вне процедуры или функции
Возврат <<?>>Ложь; (Проверка: Сервер)
{Документ.ФормированиеБригады.МодульОбъекта(20,14)}: Обнаружено логическое завершение исходного текста модуля
Возврат Ложь;<<?>> (Проверка: Сервер)

Вот сам листинг:
Функция ПроверкаЗаполненияТС (ТранспортныеСредства) ;
"ВЫБРАТЬ
| ТранспортныеСредства.Ссылка
|ИЗ
| Справочник.ТранспортныеСредства КАК ТранспортныеСредства
|ГДЕ
| ТранспортныеСредства.Ссылка = &ТС"

Запрос.УстановитьПараметр("ТС", Объект.ТС);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Если Выборка.Следующий() Тогда
//если в справочнике, есть хоть одна запись, то возвращаем значение истина
Возврат Истина;
КонецЕсли;
//в противном случае возвращаем запись ложь
Возврат Ложь;
КонецФункции

Процедура ОбработкаПроведения(Отказ, Режим)
Если ПроверкаЗаполненияТС (ТранспортныеСредства) Тогда
//переменную Отказ выставляю в значении ложь, так как если он нашел в справочнике это ТС, то значит Поле этой формы заполнено. (Возврат наверное, напишем в самом конце, после проведения).
Отказ ложь

// регистр Бригады
Движения.Бригады.Записывать = Истина;
Движение = Движения.Бригады.Добавить();
Движение.Период = Дата;
Движение.ТС = ТС;
Движение.Водитель = Водитель;
Движение.Грузчик1 = Грузчик1;
Движение.Грузчик2 = Грузчик2;
Движение.МедРаботник = МедРаботник;
Движение.ИнженерПоТБ = ИнженерПоТБ;
КонецПроцедуры

Пока весьма посредственно разбираюсь в этом, прошу помочь, как исправить код

alexandr_ll

Дудков Дмитрий, У вас в функции нет самого запроса. Нужно:

Функция ПроверкаЗаполненияТС (ТранспортныеСредства) ;
Запрос = Новый Запрос;       
Запрос.Текст = "ВЫБРАТЬ
...

Теги: 8.3 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск