Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
30 сен 2022, 00:06

Как привязать сообщение к строке с ошибкой

Автор Алексей_1985_06, 05 дек 2021, 13:04

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Всем привет! Прошу специалистов подсказать как привязать сообщение с ошибкой к строке ТЧ в которой она обнаружена, код в модуле формы такой:

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Для Каждого Строка Из Объект.СведенияОбОтсутствии Цикл

Если Строка.ДатаНачала > Строка.ДатаОкончания Тогда

Сообщение = Новый СообщениеПользователю;
Сообщение.Поле = "Объект.СведенияОбОтсутствии[Строка.НомерСтроки].ДатаНачала";
Сообщение.УстановитьДанные(ЭтотОбъект); 
Сообщение.Текст = "Измените дату: " + Формат(Строка.ДатаНачала, "ДФ=dd.MM.yyyy");
Сообщение.Сообщить();
Отказ = Истина;
КонецЕсли;

КонецЦикла;

КонецПроцедуры

Но сообщение всегда привязано к верхней строке, а не к строке в которой ошибка! Помогите исправить и довести до ума.....

antoneus

Номер строки (кстати, не номер, а индекс) надо задавать явно. Так должно взлететь

Сообщение.Поле = СтрШаблон("Объект.СведенияОбОтсутствии[%1].ДатаНачала", Объект.СведенияОбОтсутствии.Индекс(Строка));

Алексей_1985_06

antoneus, Большое Вам спасибо, все получилось!  :zebzdr:  :zebzdr:  :zebzdr:

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск