Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
03 дек 2022, 16:57

Отбор задач по исполнителю

Автор Алексей_1985_06, 21 ноя 2021, 12:18

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Знатоков прошу помочь с данным вопросом:

1. В модуле сеанса определяем текущего пользователя (созданы несколько пользователей с соответствующими правами):
Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
ТекПользователь = Справочники.Сотрудники.НайтиПоНаименованию(ИмяПользователя());
Если ТекПользователь.Пустая() Тогда
НовПользователь = Справочники.Сотрудники.СоздатьЭлемент();
НовПользователь.Наименование = ИмяПользователя();
НовПользователь.Записать();
ТекПользователь = НовПользователь.Ссылка;
КонецЕсли;
ПараметрыСеанса.ТекущийИсполнитель = ТекПользователь;
КонецПроцедуры

2. Есть форма со списком задач, которая отображает список задач с отбором по исполнителю Задача.ЗадачиПоИсполнителю (в зависимости от вошедшего в систему пользователя)

Вопрос... Есть должностное лицо (начальник) которое имеет право эти задачи ставить, с целью контроля у него должен отображаться весь список задач без отбора по исполнителю. Как реализовать чтобы при входе в систему этого должностного лица (начальника) у него отображался весь перечень задач которые он поставил соответствующим сотрудникам?  :dfbbdrfb:  :dfbbdrfb:  :dfbbdrfb:

LexaK

Алексей_1985_06, так это настройка для всплывающего напоминания исполнителям по их задачам,
а можно просто перейти в задачи и открыть список задач, при наличии соответствующих прав, как раз и будет доступен весь список задачь
если помогло нажмите: Спасибо!

Алексей_1985_06

LexaK, спасибо Вам что откликнулись  :zebzdr: !

Подскажите пжл с таким вопросом
1. Сделал оповещение для формы списка задач:
&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
Оповестить("ОбновитьСписокЗадач");
КонецПроцедуры

2. Создал реквизит у сотрудника "ИмеетПравоСтавитьЗадачи" - тип булево
Если истина то, при открытии формы списка задач, группа элементов с динамическими списками (ГруппаЗадачиСОтборомПоИсполнителю) с отбором по исполнителю не отображаются, а видны ДС без отбора по исполнителю, тем самым отображается весь перечень поставленных задач:
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
Если ИмяСобытия = "ОбновитьСписокЗадач" Тогда
Элементы.ОткрытыеЗадачи.Обновить();
Элементы.ЗадачиВРаботе.Обновить();
Элементы.ВыполненныеЗадачи.Обновить();
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ТекПользователь = Справочники.Сотрудники.НайтиПоНаименованию(ИмяПользователя());
Если ТекПользователь.ИмеетПравоСтавитьЗадачи Тогда // если есть отметка что имеет право ставить задачи
Элементы.ГруппаЗадачиСОтборомПоИсполнителю.Видимость = Ложь;
КонецЕсли;
КонецПроцедуры


Но столкнулся с такой проблемой, что при записи задачи возникает ошибка: "МЕТОД НЕДОСТУПЕН ДЛЯ НЕВИДИМОГО ЭЛЕМЕНТА"
Подскажите, это как-то можно исправить

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск