Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:46

Не получается получить результат база

Автор Дмитрий357, 10 ноя 2021, 19:12

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий357

Добрый день! Не получается подсчитать премию, не выдает значение РезультатБаза. Проверял в консоли запросов запрос выдает ошибку {(5, 4)}: Ошибка обработки представления "РегистрРасчета.ДополнительныеНачисления.БазаОсновныеНачисле ния:Не задан параметр Измерения основного регистра". Хотя в парметрах виртуальной таблицы ДопНачисления все задано
<<?>>РегистрРасчета.ДополнительныеНачисления.БазаОсновныеНач исления(
Движения.ДополнительныеНачисления.Записывать=Истина;
    Для Каждого ТекСтрокаНачисленияДоп Из НачисленияДоп Цикл
        Движение2=Движения.ДополнительныеНачисления.Добавить();
        Движение2.Сторно=Ложь;
        ЗаполнитьЗначенияСвойств(Движение2, ТекСтрокаНачисленияДоп);
        Движение2.ВидРасчета=ТекСтрокаНачисленияДоп.ВидНачисления;
        Движение2.ПериодРегистрации=Дата;
        Если Движение2.ВидРасчета=ПланыВидовРасчета.ДополнительныеНачисления.Премия Тогда
            ПрошлыйМесяц=ДобавитьМесяц(Дата, -1);
            Движение2.БазовыйПериодНачало=НачалоМесяца(ПрошлыйМесяц);
            Движение2.БазовыйПериодКонец=КонецМесяца(ПрошлыйМесяц);
        Иначе
            Движение2.БазовыйПериодНачало=НачалоМесяца(Дата);
            Движение2.БазовыйПериодКонец=КонецМесяца(Дата);
        КонецЕсли;
    КонецЦикла;
    Движения.ДополнительныеНачисления.Записать();
   
        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   ДополнительныеНачисленияБазаОсновныеНачисления.НомерСтроки КАК НомерСтроки,
        |   ДополнительныеНачисленияБазаОсновныеНачисления.РезультатБаза КАК РезультатБаза
        |ИЗ
        |   РегистрРасчета.ДополнительныеНачисления.БазаОсновныеНачисления(
        |           &МассивИзмерений,
        |           &МассивИзмерений,
        |           ,
        |           Регистратор = &Ссылка
        |               И ВидРасчета = &Премия) КАК ДополнительныеНачисленияБазаОсновныеНачисления";
   
    МассивИзмерений=Новый Массив;
    МассивИзмерений.Добавить("Сотрудник");
    Запрос.УстановитьПараметр("МассивИзмерений", МассивИзмерений);
    Запрос.УстановитьПараметр("Премия", ПланыВидовРасчета.ДополнительныеНачисления.Премия);
    Запрос.УстановитьПараметр("Ссылка", Ссылка);
   
    РезультатЗапроса = Запрос.Выполнить();
   
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
    Для Каждого СтрДвижение Из Движения.ДополнительныеНачисления Цикл
        ВыборкаДетальныеЗаписи.Сбросить();
        Если ВыборкаДетальныеЗаписи.НайтиСледующий(СтрДвижение.НомерСтроки, "НомерСтроки") Тогда
            СтрДвижение.Результат=СтрДвижение.Размер/100*ВыборкаДетальныеЗаписи.РезультатБаза;
        КонецЕсли;
    КонецЦикла;

Ивашка

Дмитрий357, а зачем два раза задаешь параметр &МассивИзмерений в виртуальной таблице?

Дмитрий357

Ивашка, Для измерений базового регистра и для измерений основного регистра

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск