Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 ноя 2022, 14:17

Копирование с одной ТЗ в другую

Автор Denis1010, 01 ноя 2021, 23:51

0 Пользователей и 1 гость просматривают эту тему.

Denis1010

Доброй ночи. У меня есть ТЗСтаж, и из этой ТЗ мне нужно скопировать все строки со значениями с колонки "ТабельныйНомер", в другую ТЗ.
Написал вот такой код, но выдаёт ошибку "Метод объекта не обнаружен (скопировать)". Не могу понять в чём моя ошибка. Благодарен каждому за помощь!

&НаСервере
Процедура СкопироватьНаСервере()

ТЗ1 = Новый ТаблицаЗначений;
ТЗ1 = ТЗСтаж.Скопировать("ТабельныйНомер");

КонецПроцедуры

&НаКлиенте
Процедура Скопировать(Команда)
СкопироватьНаСервере();
КонецПроцедуры

ls600

копирование тз

Как скопировать, выгрузить данные из одной таблицы значений в другую?

+8

Распечатать

Как скопировать или выгрузить данные из одной таблицы значений в другую таблицу значений?

1. Добавление, копирование строк из одной таблицы значений в другую таблицу значений:

Код 1C v 8.х Для каждого СтрокаТЗ Из Таблица1 Цикл
ЗаполнитьЗначенияСвойств(Таблица2.Добавить(), СтрокаТЗ)
КонецЦикла;

2. Можно использовать метод Скопировать() объекта ТаблицаЗначений:

Первым параметром в этот метод передается массив строк для копирования, если он не указан - копируются все строки таблицы значений. Этот параметр также может содержать отбор по значению колонок.

Вторым параметром передается список колонок для копирования в формате "Колонка1, Колонка2...". Если параметр не указан, копируются все колонки таблицы.

Допустим, есть таблица значений ТЗ с колонками Код, Номенклатура и Цена.

С помощью следующего кода мы выгрузим из этой таблицы в новую таблицу значений ТЗ1 все значения, содержащиеся в колонках Номенклатура и Цена:

Код 1C v 8.х ТЗ1 = Новый ТаблицаЗначений;
ТЗ1 = ТЗ.Скопировать("Номенклатура,Цена");

В следующем примере мы выгрузим все строки исходной таблицы, в которых значение поля Цена = 15000.

Код 1C v 8.х ТЗ1 = Новый ТаблицаЗначений;
ПараметрыОтбора = Новый Структура("Цена",15000);
ТЗ1 = ТЗ.Скопировать(ПараметрыОтбора);

Denis1010

Спасибо, решил уже свою проблему, всё оказалось намного проще)
Для каждого тзСтрока Из ТЗСтаж Цикл

ЗаполнитьЗначенияСвойств(ТЗТабельныеНомера.Добавить(), тзСтрока);

КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск