Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 авг 2022, 10:32

Фиксация времени работы с документом

Автор Sympak, 05 окт 2021, 14:00

0 Пользователей и 1 гость просматривают эту тему.

Sympak

Добрый день.
Поставлена задача отобразить в "Реквизите сведений - РегистрацияОбъектов", время открытия и закрытия конкретного справочника.
Сейчас в Реквизите сведений отображен Период/время (фиксируется только при изменении объектов в справочнике), Методанные (адрес объекта) и Состояние ("В разработке", "К выгрузке", "Доставлен").

LexaK

можно использовать события формы
&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ЗафиксироватьСобытие("Открытие");
КонецПроцедуры

и

&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)
   ЗафиксироватьСобытие("Закрытие");
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗафиксироватьСобытие(ИмяСобытия);
//здесь вставьте код записи в РС
//еще добавьте Пользователя, кто открывал/закрывал форму
ДатаСобытия = ТекущаяДата();
...//и т.д.
КонецПроцедуры
если помогло нажмите: Спасибо!

Sympak

LexaK, Спасибо. А к версии 1С:Предприятие 8.2 это применить можно?
Начинающий программист и много не знаю еще

LexaK

Конечно.
(пробуйте, пишите если что не получится)

формы какие? режим запуска?
если помогло нажмите: Спасибо!

Sympak


LexaK

если помогло нажмите: Спасибо!

Sympak


LexaK

если помогло нажмите: Спасибо!

Sympak


Теги: разработка 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск