Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
07 июн 2023, 03:10

Ни как не удалить документы в 1С!!! ХЕЛП!!!!

Автор Ольга Николаева, 13 мая 2011, 12:10

0 Пользователей и 1 гость просматривают эту тему.

Ольга Николаева

Подскажите, пожалуйста. Мне надо удалить почти все документы, но не удалять номенклатуру.
Вошла в 1С, как администратор, монопольно. Пометила все документы на удаление. Открыла удаление помеченных объектов. Но документы как были, так и есть. Они НЕ удаляются. Пишет, что удалить невозможно. Что делать?????? :dfbsdfbsdf:

volodya1122

Некоторые документы всеже удалились? Если помечены не все документы, то в этих непомеченных документах есть ссылки на помеченные. (тоисть вы делали например "Ввод на основании"). е еще в документах которые непомечены на удаление есть товар(номенклатура) которая например была в документе "приход" - который вы питаетесь удалить. такое невозможно сделать. И почему все документы не пометили? непонятна суть почему нужно удалять не все документы.

prog1c7.7

//нужна небольшая обработка (если документы действительно не нужны), в личку обращайтесь напишу.
// для форума (хотя и так все знают)
Процедура Сформировать()
Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() = 1 Цикл
Док.Удалить(1);
КонецЦикла;
КонецПроцедуры



prog1c7.7

ну дык я и говорю что это несоветский такой метод, если
"документы действительно не нужны"

Ольга Николаева


maleks

а подскажите, как пометить на удаление все документы, а не тыкать на каждый по отдельности? заранее спасибо.

volodya1122

написать обработку которая это сделает....

volodya1122

Вот пример для пометки на удаления расходных накладных

Процедура Сформировать()
Док3=СоздатьОбъект("Документ.РасходнаяНакладная");
Док3.ВыбратьДокументы(Дата1,ДатаПо); 
Пока Док3.ПолучитьДокумент()=1 Цикл 
Сообщить("Розх. накл. "+Док3.ДатаДок+"  "+Док3.НомерДок);
    Док3.Удалить(0);
КонецЦикла;
Сообщить("Расхожные накладные помеченные на удаления");
КонецПроцедуры

Процедура ПриОткрытии() 
Дата1 = "01.01.2000";
ДатаПо = "01.01.2000";

КонецПроцедуры



volodya1122

Если вообще все документы за выбраный период то изменить код

СоздатьОбъект("Документ.РасходнаяНакладная");

на

СоздатьОбъект("Документ");

Таня222

Помогите пожалуйста с проблемой.
помечаю на удаление накладные на реализацию через обработку док.все накладные помечены,открываю "удаление пом. объектов" в поле где должны быть все док. помеченные на удаление из допустим 20 накладных только 3,нажимаю поиск ничего не происходит.т.е не выводятся помеченные на удаление документы в поле контроля.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск