Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 июн 2022, 07:24

Вывод значений в табличную часть из другого документа

Автор Lecowi, 06 июн 2019, 20:30

0 Пользователей и 1 гость просматривают эту тему.

Lecowi

Помогите разобраться с вопросом.
Есть два документа:
Отпуск материалов с табличной частью ОтгружаемыеТовары
ИнвентаризацияМатериалов с табличной частью Материалы
В документе ОтпускМатериалов создан реквизит Инвентаризация, который имеет тип ДокументСсылка.ИнвентаризацияМатериалов, также на форме документа создана кнопка ЗаполнитьПоИнвентаризации.
Необходимо при выборе значений в поле Инвентаризация, по нажатию кнопки заполнялась табличная часть документа ОтпускМатериалов из документа ИнвентаризацияМатериалов.
Вот исходный код:

&НаКлиенте
Процедура ЗаполнитьПоИнвентаризации(Команда)
Если Объект.Инвентаризация.Пустая() Тогда
Возврат;
КонецЕсли;
ЗаполнитьПоИнвентаризацииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьПоИнвентаризацииНаСервере()
Массив = Инвентаризация.Выгрузить();
Объект.ОтгружаемыеТовары.Загрузить(Массив);
КонецПроцедуры

LexaK

попробуйте так

&НаСервере
Процедура ЗаполнитьПоИнвентаризацииНаСервере()
   ОтгружаемыеТовары.Загрузить(Инвентаризация.Материалы.Выгрузить());
КонецПроцедуры
если помогло сказать: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск