Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 июн 2022, 08:27

Помогите, не получается посчитать себестоимость по услугам, отдельно от товаров

Автор nastyaru0898, 08 ноя 2018, 11:13

0 Пользователей и 1 гость просматривают эту тему.

nastyaru0898

Не считает себестоимость услуги, себестоимость товаров считает без проблем. По моему мнению, ошибка где-то в "Запросе", а где не знаю. Помогите как исправить

это общий модуль установки цен:


   Движения.ЦеныНоменклатуры.Записывать = Истина;
   Движения.СебестоимостьУслуги.Записывать = Истина;
   Для Каждого ТекСтрокаТовары Из Товары Цикл
      Если ТекСтрокаТовары.Номенклатура.Услуга = Ложь Тогда
         Движение = Движения.ЦеныНоменклатуры.Добавить();
         Движение.Период = Дата;
         Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
         Движение.Цена = ТекСтрокаТовары.Цена;
      Иначе
         Движение = Движения.СебестоимостьУслуги.Добавить();
         Движение.Период = Дата;
         Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
         Движение.Себестоимость = ТекСтрокаТовары.Цена;
      КонецЕсли;
   КонецЦикла;

Это часть модуля,а именно то, что отвечает за себестоимость услуги:
Иначе   

         Запрос = Новый Запрос ("ВЫБРАТЬ
                                |   СебестоимостьУслугиСрезПоследних.Номенклатура,
                                |   СебестоимостьУслугиСрезПоследних.Себестоимость,
                                |ИЗ
                                |   РегистрСведений.СебестоимостьУслуги.СрезПоследних КАК СебестоимостьУслугиСрезПоследних") ;
            Запрос.УстановитьПараметр("Дата",Дата);
            Запрос.УстановитьПараметр("Номенклатура", СтрокаИзДокумента.Номенклатура);
            
            
            Выборка = Запрос.Выполнить().Выбрать();
            Если Выборка.Следующий() Тогда
               СебестоимотьУслуги = Выборка.Себестоимость;
            Иначе
               СебестоимостьУслуги = 0;
            КонецЕсли;
            ОбщаяСебестоимость = СебестоимостьУслуги * СтрокаИзДокумента.Количество;

oleg-x

         Запрос = Новый Запрос ("ВЫБРАТЬ
                                |   СебестоимостьУслугиСрезПоследних.Номенклатура,
                                |   СебестоимостьУслугиСрезПоследних.Себестоимость,
                                |ИЗ
                                |   РегистрСведений.СебестоимостьУслуги.СрезПоследних КАК СебестоимостьУслугиСрезПоследних") ;
            Запрос.УстановитьПараметр("Дата",Дата);
            Запрос.УстановитьПараметр("Номенклатура", СтрокаИзДокумента.Номенклатура);

Либо не полностью выложили, либо хрень полнейшая.
Параметры устанавливаете, но где эти параметры в самом запросе?
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

wise

(0) может    РегистрСведений.СебестоимостьУслуги.СрезПоследних(&ВыбДата, Номенклатура = &ВыбНоменклатура)

Запрос.УстановитьПараметр("ВыбДата",Дата);
Запрос.УстановитьПараметр("ВыбНоменклатура", СтрокаИзДокумента.Номенклатура);
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск