Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 21:37

Как обратиться к реквизиту справочника в модуле менеджера

Автор Nut345, 25 авг 2018, 19:36

0 Пользователей и 1 гость просматривают эту тему.

Nut345

Есть справочник Договоры Контрагентов в нем создан макет active document и команда. Подскажите пожалуйста как получить реквизит справочника?     

// Модуль Менеджера
Процедура ДоговорСПоставщиком(ТабДок, Ссылка)Экспорт

ДоговорСПоставщиком =  ПолучитьМакет("ДоговорСПоставщиком");
MSWord = ДоговорСПоставщиком.Получить();

Попытка
Документ = MSWord.Application.Documents (1);
Документ.Activate ();

Замена = Документ.Content.Find;
    Замена.Execute("<Nomerdogovora>", Ложь, Истина, Ложь, , , Истина, , Ложь, Объект.НомерДоговора);

Замена = Документ.Content.Find;
    Замена.Execute("<Data>", Ложь, Истина, Ложь, , , Истина, , Ложь,Объект.ДатаДоговора);

Замена = Документ.Content.Find;
    Замена.Execute("<NameOrg>", Ложь, Истина, Ложь, , , Истина, , Ложь, """" + Объект.Владелец + """");

MSWord.Application.Visible = Истина;
MSWord.Activate ();

Исключение
     Сообщение = Новый СообщениеПользователю();
Сообщение.Текст = ОписаниеОшибки();
Сообщение.Сообщить();
MSWord.Application.Quit();
КонецПопытки;
КонецПроцедуры

//Модуль Команды

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
ДоговорСПоставщиком(ТабДок, ПараметрКоманды);
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
КонецПроцедуры

Процедура ДоговорСПоставщиком (ТабДок, ПараметрКоманды);
Справочники.ДоговорыКонтрагентов.ДоговорСПоставщиком(ТабДок, ПараметрКоманды);
КонецПроцедуры    




AIFrame


Nut345


Дмитрий Медведков

Добрый день!
В модуле менеджера нет доступа к реквизитам справочника (не важно чем является справочник - ссылкой или объектом). Единственный вариант здесь - передавать сам справочник (ссылку или объект) в качестве параметра в процедуру/функцию модуля менеджера
coderstar.ru - Отчеты, обработки и расширения 1С. Самоучители по Бухгалтерии 3.0 и Торговле 11.4

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск