Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 фев 2023, 03:54

Табличная часть и подчиненная таблица значений.

Автор alex.kruglov, 28 мая 2018, 11:28

0 Пользователей и 1 гость просматривают эту тему.

alex.kruglov

Здравствуйте!

На форме есть табличная часть (ТЧ) и таблица значений (ТЗ). При выборе строки в ТЧ, меняется информация в ТЗ. Вопрос: Например, по кнопке, перебрать все строки в ТЧ и при этом получить обновленные данные из ТЗ, как?

alexandr_ll

Цитата: alex.kruglov от 28 мая 2018, 11:28
Здравствуйте!

На форме есть табличная часть (ТЧ) и таблица значений (ТЗ). При выборе строки в ТЧ, меняется информация в ТЗ. Вопрос: Например, по кнопке, перебрать все строки в ТЧ и при этом получить обновленные данные из ТЗ, как?
Что значит "получить обновленные данные из ТЗ"? ЕЕ надо показать или куда-то передать? Поподробнее про задачу

alex.kruglov

"показать", вообще, прочитать из нее данные в зависимости от того какая строка у ТЧ (у ТЧ, перебрать все строки, в цикле например)

alexandr_ll

Цитата: alex.kruglov от 28 мая 2018, 12:53
"показать", вообще, прочитать из нее данные в зависимости от того какая строка у ТЧ (у ТЧ, перебрать все строки, в цикле например)
Функция ЗаполнитьТЗ()
ТЗ=АлгоритмЗаполнения();
Возврат ТЗ;
КонецФункции
Процедура Обновить();
ТЗ.УдалитьСтроки();
ВыбратьСтроки(); // для ТЧ
Пока ПолучитьСтроку()=1 Цикл
ЗаполнитьТЗ()
КонецЦикла;
КонецПроцедуры

alex.kruglov

Совсем не то!

Смотрите, у меня есть ТЧ с заполненными строками. И есть ТЗ, строки в которой, заполняются в зависимости от выбора строки ТЧ.

Вопрос: Как программно перебрать все строки в ТЧ и соответствующие строки ТЗ?

alexandr_ll

Цитата: alex.kruglov от 29 мая 2018, 15:51Вопрос: Как программно перебрать все строки в ТЧ и соответствующие строки ТЗ?
А какое соответствие строк ТЧ и ТЗ?
Предположим, что совпадают номера строк, тогда
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
ТЗ.ПолучитьСтрокуПоНомеру(НомерСтроки);//Указанная строка ТЗ становится текущей,
//НомерСтроки-атрибут табличной части документа.
Сообщить(ТЗ.ИнтересующийРеквизит);//ну или что вас интересует в этой строке
КонецЦикла;


AIFrame

Цитата: alex.kruglov от 29 мая 2018, 15:51Смотрите, у меня есть ТЧ с заполненными строками. И есть ТЗ, строки в которой, заполняются в зависимости от выбора строки ТЧ.

Вопрос: Как программно перебрать все строки в ТЧ и соответствующие строки ТЗ?
Ну так обработай для каждой строки ТЧ событие активизации. Куда тебе это и зачем - ты не объясняешь, чо ты сделать пытаешься - ты тоже не объясняешь. Вопрос у тебя какой-то только тебе одному понятный. Ну короч такое.


alex.kruglov

to alexandr_II: соответствие? - не по номерам строк! В ТЧ строки, в ТЗ - условно, дополнительные характеристики этих строк (могут быть различными!).

to AIFrame: событие активации - как? пример, пожалуйста.


AIFrame

Цитата: alex.kruglov от 03 июн 2018, 09:51событие активации - как? пример, пожалуйста
Цитата: alex.kruglov от 29 мая 2018, 20:29ТЗ, строки в которой, заполняются в зависимости от выбора строки ТЧ.
У тебя он уже есть. Ты вызови этот механизм, перебрав строки ТЧ в цикле.
Код свой ты не даешь, пояснений не даешь, задачи не озвучиваешь.
Сеанс гадания на кофейной гуще окончен.





alexandr_ll

Цитата: alex.kruglov от 03 июн 2018, 09:51
to alexandr_II: соответствие? - не по номерам строк! В ТЧ строки, в ТЗ - условно, дополнительные характеристики этих строк (могут быть различными!).

to AIFrame: событие активации - как? пример, пожалуйста.
Как я погимаю, есть процедура или функция, по которой происходит заполнение таблицы значений по данным строки табличной частию
Тогда ваша задача -тривиальный вложенный цикл с предварительным заполнением таблицы значенй.
ВыбратьСтроки()
Пока ПолучитьСтроку()=1 Цикл
ЗаполнитьТЗ(); // ссылка на процедуру, заполнения ТЗ
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл
           КакаяТоПеременная=ТЗ.КакойтоРевизит;
    КонецЦикла;
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск