Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
10 авг 2022, 23:34

Аналог WHERE, выборка по условию

Автор Караван, 23 янв 2018, 06:47

0 Пользователей и 1 гость просматривают эту тему.

Караван

Здравствуйте!
1С:Предприятие 8.3 (8.3.4.437)

Есть рабочий запрос:
Цитировать
Процедура ВыбратьЛипкинНаСервере()
   Запрос = Новый Запрос;
       Запрос.Текст = ("ВЫБРАТЬ Наименование, Имя ИЗ Справочник.ФИО ");
       РезультатЗапроса = Запрос.Выполнить();
   ITOGO = РезультатЗапроса.Выбрать();
        Пока ITOGO.Следующий() Цикл
          Сообщить(ITOGO.Наименование+" "+
      ITOGO.Имя
      );
   КонецЦикла;
КонецПроцедуры
Результат - содержание справочника, поля "Наименование" и "Имя"
Теперь нужно выбрать конкретную запись, например, где наименование "ЛИПКИН"
Дописал:
Цитировать
Процедура ВыбратьЛипкинНаСервере()
   Запрос = Новый Запрос;
       Запрос.Текст = ("ВЫБРАТЬ Наименование, Имя ИЗ Справочник.ФИО ГДЕ Наименование = ЛИПКИН ");
   РезультатЗапроса = Запрос.Выполнить();
   ITOGO = РезультатЗапроса.Выбрать();
        Пока ITOGO.Следующий() Цикл
          Сообщить(ITOGO.Наименование+" "+
      ITOGO.Имя
      );
КонецЦикла;
КонецПроцедуры

Не работает.
Сообщение:
Цитировать
Поле не найдено "ЛИПКИН"

Что не так?

alex0402

Цитата: Караван от 23 янв 2018, 06:47Запрос.Текст = ("ВЫБРАТЬ Наименование, Имя ИЗ Справочник.ФИО ГДЕ Наименование = ЛИПКИН ");

нужно так:

Запрос.Текст = ("ВЫБРАТЬ Наименование, Имя ИЗ Справочник.ФИО ГДЕ Наименование = ""ЛИПКИН"" ")
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск