Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
10 авг 2022, 22:56

Помогите написать обработку

Автор KuBeR21, 19 янв 2018, 10:06

0 Пользователей и 1 гость просматривают эту тему.

KuBeR21

Хочу написать обработку по изменению регистра Сведений.

Хочу сделать так: в регистре сведений "ГраницыЗапретаИзмененияДанных" искать запись, которая пренадлежит пользователям, которые находится в Справочнике пользователей "Производство". Если запись есть, то изменять дату границы запрета на два дня меньше текущей.
Если записи нет, то чтобы создавал 3 записи. Без Предприятия, с Предприятием №1 и предприятием №2.
Пока дошел до того что ищет запись конкретного пользователя и изменяет. Дальше продвинуться не могу.


Процедура КнопкаВыполнитьНажатие(Кнопка)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ГруппыПользователейПользователиГруппы.Пользователь
|ИЗ
| Справочник.ГруппыПользователей.ПользователиГруппы КАК ГруппыПользователейПользователиГруппы
|ГДЕ
| ГруппыПользователейПользователиГруппы.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка", Справочники.ГруппыПользователей.НайтиПоКоду("000000006"));
Выб = Запрос.Выполнить().Выбрать();

Пока Выб.Следующий() Цикл


НаборЗаписей = РегистрыСведений.ГраницыЗапретаИзмененияДанных.СоздатьНаборЗаписей();
НаборЗаписей.Прочитать();
Для Каждого Запись Из НаборЗаписей Цикл
        // Чтение
Сообщить(Строка(Запись.Пользователь) + " " + Строка(Запись.ГраницаЗапретаИзменений));
Если Строка(Запись.Пользователь) = Строка("Илларионова Л.С.") тогда
Запись.ГраницаЗапретаИзменений=НачалоДня(ТекущаяДата())- 259200;
КонецЕсли;
НаборЗаписей.Записать();
    КонецЦикла;

НаборЗаписей.Записать();
КонецЦикла;
КонецПроцедуры



Помогите! пожалуйста!

Luzer1C

Справочники.ГруппыПользователей.НайтиПоКоду("000000006") - это группа пользователей "Производство"?

В голове у меня от такого кода какой-то когнитивный диссонанс. Даже не знаю как и чем помочь.
Халамбалам.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск