Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
10 авг 2022, 23:41

Чтение из тхт файла и запись в справочник

Автор Караван, 18 янв 2018, 08:58

0 Пользователей и 1 гость просматривают эту тему.

Караван

Платформа 7.7 (7.70.025)
Конфигурация собственная, учебная.
Требуется считать их текстового файла с:\time\1.txt одну единственную строку, состоящую из единственного слова - ИВАНОВ.
И затем вывести на экран или ( в идеале) записать в справочник.сотрудники.наименование

Могу я это сделать в Документе? Как это сделать для кнопки?

***
Сделал обработку, в модуль добавил код:

Текст = СоздатьОбъект("Текст");
Текст.Прочитать("С:\time\1.txt");
Текст.Показать;

Ничего не происходит.

AntS

Процедура Сформировать()
   
   Текст = СоздатьОбъект("Текст");
   
   Текст.Открыть("d:\1111.txt");
   
   Для  н = 1 по Текст.КоличествоСтрок() цикл 
      
      Сообщить(Текст.ПолучитьСтроку(н))
      
   КонецЦикла;   
   
   
КонецПроцедуры

nikservice

//*******************************************
Процедура Сформировать()
Текст = СоздатьОбъект("Текст");
Текст.Открыть("C:\time\1.txt");
Спр = СоздатьОбъект("Справочник.Сотрудники");
Для  н = 1 по Текст.КоличествоСтрок() цикл 
Стр = Текст.ПолучитьСтроку(н);
Спр.Новый();
Спр.Наименование = Стр;
Спр.Записать();
Сообщить(Стр);
КонецЦикла;   
КонецПроцедуры


Это плюсом создаст записи в справочнике. По количеству строк в файле.

Караван


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск