Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
10 авг 2022, 23:01

Интерактивные операции недоступны

Автор Александр Рубан, 14 янв 2018, 14:55

0 Пользователей и 1 гость просматривают эту тему.

Александр Рубан

На формусписка добавил кнопку

Команда кнопки

&НаКлиенте
Процедура РасторгнутьДоговор(Команда)
Предупреждение(Список());
КонецПроцедуры



Получение списка
&НаСервере
Функция Список()
А =  Документы.Контракт.ПолучитьФормуСписка("ФормаСписка");
Список = А.ЭлементыФормы.Найти("Список");
Каунт = Список.ВыделенныеСтроки.Количество;
Возврат Каунт;
КонецФункции


1.Если ли свойство ВыделенныеСтроки и Количество в у списка формы(я ихписал чмсто из логических соображений)
может кол-во как метод и нада скобки добавить
2.В чем вообще проблема

LexaK

в управляемом приложении, у вас включен режим
Режим использования синхронных вызовов расширений платформы и внешних компонент = Не использовать

можно
1.Изменить режим (конфигуратор свойства и т.д.)
2.Вместо процедуры Предупреждение использовать процедуру ПоказатьПредупреждение() см. СП

&НаКлиенте
Процедура РасторгнутьДоговор(Команда)
    ПоказатьПредупреждение(,""+Список());
КонецПроцедуры

если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск