Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:23

Помогите в Документах Корректировка Долга добавить ИНН контрагента

Автор sitash, 03 янв 2018, 19:07

0 Пользователей и 1 гость просматривают эту тему.

sitash

Добрый вечер!
В Документах есть документ Корректировка долга. Хотелось туда добавить новый столбец где указывается ИНН контрагента. Не получается сохранить сам документ что бы потом суда залит. Заранее спасибо.

AIFrame

Эм, ну ИНН суть реквизит контрагента. Он заполнен?
В этой конфигурации у вас колонка ИНН есть изначально и она почему-то не заполняется или вы ее сами будете добавлять, меняя форму документа в конфигураторе?
Добавлено: 03 янв 2018, 20:14


В любом случае, на обычном приложении такие манипуляции делаются по события "ПриВыводеСтроки" этой таблицы значений.
Т.е. вы добавляете в ТЧ колонку. По событии всей ТЧ (Назовем ее "СуммыДолга") "ПриВыводеСтроки" делаете:
Процедура СуммыДолгаПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
        Колонки = ЭлементыФормы.СуммыДолга.Колонки;
Если Колонки.ИНН.Видимость Тогда
ПоказатьИНН(Колонки, ОформлениеСтроки.Ячейки, ДанныеСтроки.Контрагент);
КонецЕсли;
КонецПроцедуры

Процедура ПоказатьИНН(КолонкиТабПоля, ЯчейкиСтрокиТабПоля, Контрагент)
    Если Контрагент<> Неопределено Тогда
ЯчейкиСтрокиТабПоля.ИНН.УстановитьТекст(Контрагент.ИНН);
    Иначе
ЯчейкиСтрокиТабПоля.ИНН.УстановитьТекст("");
    КонецЕсли;
КонецПроцедуры

Добавлено: 03 янв 2018, 20:15


Чет разметка в коде поехала. Ну да ладно.

sitash

ИНН я сам добавил в таблицу. но без знаний программирований ни как. может через тим вивер попробуете. буду очень признателен. после 18.00 по Москве можно подключатся. Заранее спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск