Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
03 июл 2022, 21:39

почему я не могу записать 0 в измерение регистра сведенья

Автор andron81_81, 22 дек 2017, 21:12

0 Пользователей и 1 гость просматривают эту тему.

andron81_81

Добрый вечер.

вот код на самом деле упростил задачу :

Для каждого СтрокаТЧ из Объект.РеквизитыДетали Цикл
НоваяЗапись = РегистрыСведений.БЗ_ЗначенияРеквизитов.СоздатьМенеджерЗаписи();
    НоваяЗапись.Заказ = Объект.Ссылка;
    НоваяЗапись.Объект =0;//  СтрокаТЧ.НомерДетали;
НоваяЗапись.Реквизит = Справочники.БЗ_СвойстваРеквизитов.НайтиПоНаименованию(СтрокаТЧ.Реквизит );
Если СтрокаТЧ.БылоИзменение Тогда //сохраняем только тронутые значения пользователем. Чтобы в лишний раз не нагружать сервак.

Если ЗначениеЗаполнено(СтрокаТЧ.Значение) Тогда
НоваяЗапись.Значение =СтрокаТЧ.Значение;
    НоваяЗапись.Записать(Истина);
Иначе
НоваяЗапись.Прочитать();
НоваяЗапись.Удалить();
КонецЕсли
КонецЕсли;
КонецЦикла;

1с-ке не нравится ,если в измерение Объект я записываю ноль. Видимо считается , что это пустышка. А как с этим бороться. галочку "запрет незаполненных записей" не хочется убирать. 

andron81_81

забыл отметить, что измерение объект имеет тип данных число

alex0402

Цитата: andron81_81 от 22 дек 2017, 21:12галочку "запрет незаполненных записей" не хочется убирать. 

это и означает, что ноль записывать нельзя!!!
Спасибо за Сказать спасибо

andron81_81

Цитата: alex0402 от 26 дек 2017, 08:29
Цитата: andron81_81 от 22 дек 2017, 21:12галочку "запрет незаполненных записей" не хочется убирать. 

это и означает, что ноль записывать нельзя!!!

плохо ))) ничего не сделать ?

alex0402

Спасибо за Сказать спасибо

andron81_81

Цитата: alex0402 от 26 дек 2017, 08:51
Цитата: andron81_81 от 26 дек 2017, 08:30плохо ))) ничего не сделать ?
а какие проблемы снять галку?

да собственно так и сделал. просто как-то не феншую . ладно, вопрос закрыт ....

alex0402

можно в модуле объекта разместить процедуру ОбработкаПроверкиЗаполнения и очищать параметр ПроверяемыеРеквизиты ну это в принципе то же самое, что снять галку за исключением того, что в процедуре можно проверять какие-то условия и не всегда очищать параметр ПроверяемыеРеквизиты.
Спасибо за Сказать спасибо

andron81_81

Цитата: alex0402 от 26 дек 2017, 08:57
можно в модуле объекта разместить процедуру ОбработкаПроверкиЗаполнения и очищать параметр ПроверяемыеРеквизиты ну это в принципе то же самое, что снять галку за исключением того, что в процедуре можно проверять какие-то условия и не всегда очищать параметр ПроверяемыеРеквизиты.

"галочка" выход. закрываем вопрос

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск