Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 03:15

Массовое назначение PLU кода

Автор aka_grad, 20 дек 2017, 14:37

0 Пользователей и 1 гость просматривают эту тему.

aka_grad

Доброе время суток. Может кто уже сталкивался, необходимо массово назначить PLU код для весового товара. С помощью групповой обработки выбираю весовой товар, но не знаю как сгенерировать код PLU.

Пытаюсь сделать так, но что то не присваивается код PLU
Если Объект.Весовой=Истина Тогда
НаборЗаписей = РегистрыСведений.КодыВесовогоТовара.СоздатьНаборЗаписей();
    НаборЗаписей.Прочитать();
    Для Каждого Запись Из НаборЗаписей Цикл
        Если НЕ ЗначениеЗаполнено(Запись.Код) Тогда
            Запись.Номенклатура=объект.ссылка;
            Сообщить("PLU не присвоен");
        Иначе
            Запись.Номенклатура=объект.ссылка;
            Запись.Качество = Справочники.Качество.НайтиПоКоду("000000001");;
        КонецЕсли;
    КонецЦикла;
    НаборЗаписей.Записать();
КонецЕсли;

aka_grad

Сделал так

Запрос = Новый Запрос(
    "ВЫБРАТЬ
    |   МАКСИМУМ(Регистр.Код) КАК Код
    |ИЗ
    |   РегистрСведений.КодыВесовогоТовара КАК Регистр");
    Выборка = Запрос.Выполнить().Выбрать();
   
    Результат = 1;
    Если Выборка.Количество() > 0 Тогда
        Выборка.Следующий();
        Если ЗначениеЗаполнено(Выборка.Код) Тогда
            Результат = Выборка.Код + 1;
        КонецЕсли;
    КонецЕсли;

менЗаписи = РегистрыСведений.Цены.СоздатьМенеджерЗаписи();
менЗаписи.Номенклатура = Объект.Ссылка;
менЗаписи.Код = Результат;
менЗаписи.Записать();

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск