Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 09:44

Обработка Выбора

Автор Пётр Островский, 19 дек 2017, 19:27

0 Пользователей и 1 гость просматривают эту тему.

Пётр Островский


Есть документ , где среди реквизитов ссылка на справочник и сам справочник. Мне нужно сделать так , чтобы можно было выбрать только те справочники , который не попадают в период ДатаС и ДатаДо , и статус - Свободен. Со статусом свободен решил - ПараметромВыбора у услуги. А вот с датой сложнее. Создал ОбработкуВыбора , но она не работает , помогите разобраться почему.
&НаСервере
Функция СвободенЛи(Услуга,ДатаС,ДатаДо)
    УслугаОбъект = Услуга.ПолучитьОбъект();
    Бул = ((ДатаС<УслугаОбъект.ДатаС) Или (ДатаС>УслугаОбъект.ДатаДо))И((ДатаДо>УслугаОбъект.ДатаДо)Или (ДатаДо<УслугаОбъект.ДатаС));
    возврат Бул;
КонецФункции
&НаКлиенте
Процедура УслугаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Если СвободенЛи(Элемент,ЭтотОбъект.Объект.ДатаС,ЭтотОбъект.Объект.ДатаДо) Тогда
          Сообщить(1);
      Иначе
          возврат;
    КонецЕсли
КонецПроцедуры

Golickoff

Эта обработка выбора может только сообщать "1". Если вам нужно открыть форму с отбором, напишите код открытия формы, а затем добавьте код установки отбора.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск