Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:33

Условный оператор - Сообщить

Автор vforallofus, 16 дек 2017, 18:47

0 Пользователей и 1 гость просматривают эту тему.

vforallofus


При проведении документа, если строка в коде Сообщить("что угодно") есть, документ зависает. Без этой строки, проблем нет. Выдает отказ как положено. Что сделать?

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   
   
   
   
   Для каждого ТекСтрк из Товары Цикл
      
   Если ТекСтрк.Номенклатура.Услуга = Ложь Тогда   
      
      
   
   
   
      Если ТекСтрк.КоличествоНаСкладах < ТекСтрк.Количество Тогда
      
      Сообщить("Что угодно");
      Отказ = Истина;
      
      
   
      КонецЕсли
      
      
   Конецесли;
   
   
   
   КонецЦикла;
   
   СуммаДокумента = Товары.Итог("Сумма");
   СуммаСписания = Товары.Итог("СуммаСписания");
   
   
   
КонецПроцедуры

ilyay

1. Файловая или клиент-сервер?
2. Толстый или тонкий клиент?
3. Замените на объект СообщениеПользователю.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск