Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 июл 2022, 08:44

Перемещение содержимого из группы в подгруппу через обработку

Автор Женя, 14 дек 2017, 10:23

0 Пользователей и 1 гость просматривают эту тему.

Женя

Нужна помощь
При разработке в конфигурации возникла проблема
При нажатии кнопки  записать
Нужно что бы данные из табличной части отмеченные флажками переместились из группы в подгруппу
Процедура команднаяПанельЗаписать(Кнопка)
Для каждого СтрокаТабличнойЧасти Из ОтобраннаяНоменклатура Цикл
Если СтрокаТабличнойЧасти.Пометка=Ложь Тогда
Прервать;
КонецЕсли;
КонецЦикла;
Для каждого СтрокаТабличнойЧасти Из ОтобраннаяНоменклатура Цикл
Если СтрокаТабличнойЧасти.Пометка=Истина Тогда
лНом=ОтобраннаяНоменклатура.НайтиСтроки(Новый Структура(«Пометка»,Истина));
СтрокаТабличнойЧасти=л.Ном.ПолучитьОбьект();
СтрокаТабличнойЧасти.Родитель=Подгруппа;
СтрокаТабличнойЧасти.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры;

Golickoff

Для каждого СтрокаТабличнойЧасти Из ОтобраннаяНоменклатура Цикл //Вот этот
    Если СтрокаТабличнойЧасти.Пометка=Ложь Тогда                      //кусок кода
        Прервать;                                                     //это круто
    КонецЕсли;                                                        //(на самом деле
КонецЦикла;                                                           //он не нужен)
Для каждого СтрокаТабличнойЧасти Из ОтобраннаяНоменклатура Цикл
    Если СтрокаТабличнойЧасти.Пометка=Истина Тогда    //"Если А = Истина Тогда" всегда можно заменить на "Если А Тогда"       
        лНом=ОтобраннаяНоменклатура.НайтиСтроки(Новый Структура(«Пометка»,Истина));
        СтрокаТабличнойЧасти=л.Ном.ПолучитьОбьект();  //откуда взялось л.Ном? О_о И как по вашему строка табличной части должна превратиться в СправочникОбъект? О_О
        СтрокаТабличнойЧасти.Родитель=Подгруппа;
        СтрокаТабличнойЧасти.Записать();
    КонецЕсли;
КонецЦикла;
КонецПроцедуры;

Короче, вам надо вот так
Для Каждого СтрокаТабличнойЧасти Из ОтобраннаяНоменклатура Цикл
    Если СтрокаТабличнойЧасти.Пометка Тогда       
        НоменклатураОбъект = СтрокаТабличнойЧасти.Номенклатура.ПолучитьОбъект(); //Тут я просто надеюсь на то, что в этой табличной части есть реквизит Номенклатура с типом значения СправочникСсылка
        НоменклатураОбъект.Родитель = Подгруппа;
        НоменклатураОбъект.Записать();
    КонецЕсли;
КонецЦикла;
КонецПроцедуры;
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск