Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 08:55

СКД УФ. ДанныеРасшифровки

Автор mkv, 14 дек 2017, 09:15

0 Пользователей и 1 гость просматривают эту тему.

mkv

Добра всем

Помогите, как получить расшифровку ячеек отчета в СКД на УФ
Как достучаться до ДанныеРасшифровки? Третий день интернеты безрезультатно курю ((
с обычными формами вроде всё проще, а тут, в ДанныеРасшифровки у меня тип "Строка"
Как по человечьи то их получить?
Спасибо

Задача:
Из отчета, по клику на строке, ввести новый документ с параметрами из результатов отчета


&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка, ДополнительныеПараметры)
Перем ВыбранноеДействие;
Перем ПараметрыВыбранногоДействия;
СтандартнаяОбработка = Ложь;
ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных (ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных (Отчет));

ДоступныеДействия = Новый Массив;
ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
//ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Отфильтровать);
//ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.Расшифровать);

ДополнительныеДействия = Новый СписокЗначений;
ДополнительныеДействия.Добавить("УстановитьРелиз", "Установить новый релиз");

ОбработкаРасшифровки.ПоказатьВыборДействия(Новый ОписаниеОповещения("РезультатОбработкаРасшифровкиЗавершение", ЭтотОбъект, Новый Структура("ВыбранноеДействие, ПараметрыВыбранногоДействия, Расшифровка", ВыбранноеДействие, ПараметрыВыбранногоДействия, Расшифровка)), Расшифровка, ДоступныеДействия, ДополнительныеДействия);

КонецПроцедуры

&НаКлиенте
Процедура РезультатОбработкаРасшифровкиЗавершение( ВыбранноеДействие,  ПараметрыВыбранногоДействия, ДополнительныеПараметры1) Экспорт

Расшифровка = ДополнительныеПараметры1.Расшифровка;

Если ПараметрыВыбранногоДействия <> Неопределено Тогда
Если ВыбранноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение Тогда
ПоказатьЗначение(Новый ОписаниеОповещения("РезультатОбработкаРасшифровкиЗавершение", ЭтотОбъект), ПараметрыВыбранногоДействия);
КонецЕсли;
Иначе
Если ВыбранноеДействие = "УстановитьРелиз" Тогда
Сообщить ("Установка");
//НовДок = СоздатьДокументРелизНаСервере ();
//ДокПараметры = Новый Структура("Конфигурация", );
//ДокФорма = ПолучитьФорму("Документ.ИзменениеРелизаКонфигурации.ФормаОбъекта");

Поле =  ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля ()[0];
Поле = ПолучитьПолеНаСервере (ДанныеРасшифровки, Расшифровка);
Сообщить("Поле: " + Поле.Поле + ", значение: " + Поле.Значение);


//ДокФорма.Открыть ();

КонецЕсли;
КонецЕсли;

КонецПроцедуры

mkv

Блин. я шляпа
вроде получилось. просто оставлю это тут
функцию добавил серверную. правда как то скудно с инфо о том как правильно получать

&НаКлиенте
Процедура РезультатОбработкаРасшифровкиЗавершение( ВыбранноеДействие,  ПараметрыВыбранногоДействия, ДополнительныеПараметры1) Экспорт
Расшифровка = ДополнительныеПараметры1.Расшифровка;
Релиз = получитьРасшифровкуНаСервере (Расшифровка);
..........
&НаСервере
Функция ПолучитьРасшифровкуНаСервере(Расшифровка)
Данные = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
........
КонецФункции 



Теги:

Похожие темы (1)

Рейтинг@Mail.ru Rambler's Top100

Поиск