Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 09:52

Недостаточно фактических параметров

Автор Nub-Filin, 13 дек 2017, 04:09

0 Пользователей и 1 гость просматривают эту тему.

Nub-Filin

Здравствуйте.Подскажите пожалуйста.Платформа 8.3.При попытке вывести табличный документ выдает ошибку Недостаточно фактических параметров

&НаКлиенте
Процедура СформироватьТаблицу(Команда)
   ЗаполнитьТабДок(ТабДок);
   
КонецПроцедуры
&НаСервереБезКонтекста
Процедура ЗаполнитьТабДок(ТабДок)
   
   
   Макет = Отчеты.ПрайсЛист.ПолучитьМакет("Макет");
   
   ОблШапка = Макет.ПолучитьОбласть("Шапка");
   ОблЭлемент = Макет.ПолучитьОбласть("Элемент");
   
   
   ОблШапка.Параметры.ДатаОтчета = ТекущаяДата();
   ТабДок.Вывести(ОблШапка);
   
   Выборка = Справочники.Номенклатура.ВыбратьИерархически();
   
   Пока Выборка.Следующий() Цикл
      ОблЭлемент.Параметры.Заполнить();
      ТабДок.Вывести(ОблЭлемент);
   КонецЦикла;
КонецПроцедуры

Kerbert

Цитата: Nub-Filin от 13 дек 2017, 04:09
Здравствуйте.Подскажите пожалуйста.Платформа 8.3.При попытке вывести табличный документ выдает ошибку Недостаточно фактических параметров

&НаКлиенте
Процедура СформироватьТаблицу(Команда)
   ЗаполнитьТабДок(ТабДок);
   
КонецПроцедуры
&НаСервереБезКонтекста
Процедура ЗаполнитьТабДок(ТабДок)
   
   
   Макет = Отчеты.ПрайсЛист.ПолучитьМакет("Макет");
   
   ОблШапка = Макет.ПолучитьОбласть("Шапка");
   ОблЭлемент = Макет.ПолучитьОбласть("Элемент");
   
   
   ОблШапка.Параметры.ДатаОтчета = ТекущаяДата();
   ТабДок.Вывести(ОблШапка);
   
   Выборка = Справочники.Номенклатура.ВыбратьИерархически();
   
   Пока Выборка.Следующий() Цикл
      ОблЭлемент.Параметры.Заполнить();
      ТабДок.Вывести(ОблЭлемент);
   КонецЦикла;
КонецПроцедуры
ОблЭлемент.Параметры.Заполнить();
ошибка в этой строке , тк этот метод не может принимать пустое значение , ему нужно передавать объект, посмотри справку

Nub-Filin

ОблЭлемент.Параметры.Заполнить(Выборка)

Да благодарю вас вы совершенно правы.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск