Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 18:40

Редактирование Макета

Автор Валерия Саблина, 08 дек 2017, 16:09

0 Пользователей и 1 гость просматривают эту тему.

Валерия Саблина

После того как отредактировала процедуру печать в модуле менеджера документа при нажатии клавиши печать выдает ошибку поле объекта не обнаружено (ВсегоПоДокументу)
в макете было создано поле ВсегоПоДокументу
Модуль менеджер:


Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   Макет = Документы.ОказаниеУслуги.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ОказаниеУслуги.Врач,
   |   ОказаниеУслуги.Дата,
   |   ОказаниеУслуги.Клиент,
   |   ОказаниеУслуги.Номер,
   |   ОказаниеУслуги.Склад,
   |   ОказаниеУслуги.ПереченьНоменклатуры.(
   |      НомерСтроки,
   |      Номенклатура,
   |      Количество,
   |      Цена,
   |      Сумма
   |   )
   |ИЗ
   |   Документ.ОказаниеУслуги КАК ОказаниеУслуги
   |ГДЕ
   |   ОказаниеУслуги.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   Шапка = Макет.ПолучитьОбласть("Шапка");
   ОбластьПереченьНоменклатурыШапка = Макет.ПолучитьОбласть("ПереченьНоменклатурыШапка");
   ОбластьПереченьНоменклатуры = Макет.ПолучитьОбласть("ПереченьНоменклатуры");
   ОбластьИтог = Макет.ПолучитьОбласть("Всего");
   ТабДок.Очистить();

   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;

      ТабДок.Вывести(ОбластьЗаголовок);

      Шапка.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Шапка, Выборка.Уровень());

      ТабДок.Вывести(ОбластьПереченьНоменклатурыШапка);
      ВыборкаПереченьНоменклатуры = Выборка.ПереченьНоменклатуры.Выбрать();
      СуммаИтог = 0;
      Пока ВыборкаПереченьНоменклатуры.Следующий() Цикл
         ОбластьПереченьНоменклатуры.Параметры.Заполнить(ВыборкаПереченьНоменклатуры);
         ТабДок.Вывести(ОбластьПереченьНоменклатуры, ВыборкаПереченьНоменклатуры.Уровень());
         СуммаИтог = СуммаИтог + ВыборкаПереченьНоменклатуры.Сумма;
      КонецЦикла;
      
      ОбластьИтог.Параметры.ВсегоПоДокументу = СуммаИтог;
      ТабДок.Вывести(ОбластьИтог);

      ВставлятьРазделительСтраниц = Истина;
   КонецЦикла;
   //}}
КонецПроцедуры

Kironten

Либо оно не в области "Всего" либо не тип параметр.

Валерия Саблина

Цитата: Kironten от 08 дек 2017, 16:48
Либо оно не в области "Всего" либо не тип параметр.
Все эти условия соблюдены

Kironten

Цитата: Валерия Саблина от 08 дек 2017, 18:40
Цитата: Kironten от 08 дек 2017, 16:48
Либо оно не в области "Всего" либо не тип параметр.
Все эти условия соблюдены
Скрин, со свойствами этого параметра можете показать?
И еще. Как вариант может быть не тот макет вызывается.

Валерия Саблина

Вот

pavl_vs

Валерия Саблина, Вы ошиблись, записав в имя ячейки имя параметра ВсегоПоДокументу.

Внимательно посмотрите на вашу картинку:
имя этого параметра надо вписать в разделе Свойства/Макет/Параметр, т.е. после поля Свойства/Макет/Заполнение.
Нужное поле у вас пустое.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск