Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 18:35

Отбор данных по владельцу в динамическом списке - 1С

Автор Аля Тина, 08 дек 2017, 12:39

0 Пользователей и 1 гость просматривают эту тему.

Аля Тина

Конфигурация
1С:Розница
В общем, тема такая.
Есть 2 справочника. Партнеры (владелец) и Контакты(подчиненный справочник).
На форме Партнеры создала реквизит - динамический список и заполнила его справочником Контакты.
Мне надо, чтобы в этом динамическом списке была выборка по владельцу. На данный момент список выводит все данные, которые есть в справочнике Контакты.
Прикладываю картинку, чтобы было понятнее о чем я речь веду.
Спасибо за внимание.
1С только обучаюсь.

AIFrame

После указания основной таблицы переключи в произвольный запрос, добавь условие .Владелец = &Владелец.
В модуле формы сделай:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Таблица.Параметры.УстановитьЗначениеПараметра("Владелец", Объект.Ссылка);
КонецПроцедуры

Аля Тина

Цитата: AIFrame от 09 дек 2017, 09:38
После указания основной таблицы переключи в произвольный запрос, добавь условие .Владелец = &Владелец.
В модуле формы сделай:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Таблица.Параметры.УстановитьЗначениеПараметра("Владелец", Объект.Ссылка);
КонецПроцедуры


Не получается. Ошибки выдает. Или я делаю что-то не так.


AIFrame

:kmtu:
Делаешь.
Вместо Таблица - название объекта формы с динамическим списком
В динамическом списке не указана основная таблица, а можно указать, запрос по одному справочнику.
Где в запросе ГДЕ? Где условие с параметром Владельца?

LexaK

в управляемых формах, в конфигураторе, есть настройка связи между данными по владельцу, поищите ее, настройте! В этом случае ни чего программировать не надо, при выборе одного элемента справочника, будут автоматически показываться подчиненные элементы другого. (смотрите пример в любой базе 1С)   
если помогло нажмите: Спасибо!

Аля Тина

Цитата: AIFrame от 09 дек 2017, 20:53
:kmtu:
Делаешь.
Вместо Таблица - название объекта формы с динамическим списком
В динамическом списке не указана основная таблица, а можно указать, запрос по одному справочнику.
Где в запросе ГДЕ? Где условие с параметром Владельца?
Извините за страшнейший тупак.... Но пока как то так
Добавлено: 13 дек 2017, 09:12


вот решение:

Создала в подчиненных справочниках реквизит организация с тем же типом, что и реквизит на форме партнеры.


1CВыделить код
1
2
3
4
5
6
7
8
9
&НаСервере
Процедура Контакты1ПриЗагрузкеПользовательскихНастроекНаСервере(Элемент, Настройки)
ЭлементОтбора = Контакты.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Организация");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = Объект.Компания;

КонецПроцедуры


Тема закрыта!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск